<!doctype html>
<html>
<head>
<meta charset="UTF-8" />
<title>Kanye West Joins Teyana Taylor in 'SNL' Performance: Watch | SPIN</title>
<link rel="icon" href="https://assets.spin.com/favicon.ico" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width">
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://www.spin.com/feed">
<link rel="stylesheet" href="https://www.spin.com/wp-content/themes/spin/assets/css/style.css?e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09" type="text/css" media="screen" />

<script type="text/javascript">
	
			clarityPageData = {"site_code":"spin","zone":"article_page"};
	
    (function(){
    window.CLARITY = window.CLARITY || [];
    var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
    ns.async = true; ns.type = 'text/javascript'; ns.src = '//lib.pgmcdn.com/clarity-1536861412649.min.js'; s.parentNode.insertBefore(ns, s);
})();
</script> <script type="text/javascript">
    (function(){
        window.moatYieldReady = function() {
            window.moatPrebidApi.setMoatTargetingForAllSlots();
        };

        var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
        ns.async = true; ns.type = 'text/javascript'; ns.src = '//sejs.moatads.com/billboardprebidheader946633233358/yi.js'; s.parentNode.insertBefore(ns, s);
    })();
</script>
<script>
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    apstag.init({
        pubID: 3125,
        adServer: 'googletag',
        videoAdServer: 'DFP',
        bidTimeout: 600
    });

    // Tell Clarity not to load a9
    CLARITY.push({
        use: ['header'],
        run: function(header) {
            header.skipJsInject('a9');
        }
    });
</script>
<script>
            var OX_dfp_ads = [
                            ['/6419/spin/article_page/leaderboard_bottom_lazy', ['728x90','970x250','970x90'], 'leaderboard_bottom_lazy_1', {"pos":[""], "pagetype": [""]}],
                            ['/6419/spin/article_page/leaderboard_top', ['728x90','970x250','970x90'], 'leaderboard_top_1', {"pos":[""], "pagetype": [""]}],
                            ['/6419/spin/article_page/medrec_bottom_lazy', ['300x250','300x600'], 'medrec_bottom_lazy_1', {"pos":[""], "pagetype": [""]}],
                            ['/6419/spin/article_page/medrec_top', ['300x250','300x600'], 'medrec_top_1', {"pos":[""], "pagetype": [""]}],
                        ];
        </script><script>
            // add oxDone, this is added again in Clarity but if OX managed to come back between now and header.run we would miss it
            window.oxDone = function() { 
                CLARITY.push({
                    use: ['header', 'logger'],
                    run: function(header, logger) {
                        try {
                            logger.log("Setting OX targeting from template Clarity push", "header");
                            header.partners.openx.setTargeting();
                        } catch (e) {
                            logger.log("header.oxSetTargeting failed with error : " + e,"error");
                        }
                    }
                });
            };
            // Inject OpenX script tag
            (function() {
                    var s = document.createElement('script');
                        s.type = 'text/javascript';
                        s.async = true;
                        s.src = (document.location.protocol === 'https:' ? 'https:' : 'http:') + '//spinmedia-d.openx.net/w/1.0/jstag?nc=6419-SPIN';
                    var node = document.getElementsByTagName('script')[0];
                        node.parentNode.appendChild(s);
                })();
            // Tell Clarity not to load OpenX
            CLARITY.push({
                use: ['header'],
                run: function(header) {
                    header.skipJsInject('openx');
                }
            });
        </script>
<script>
            var rubicontag = rubicontag || {};
                rubicontag.cmd = rubicontag.cmd || [];

            // Load rubicon
            (function() {
                var account_id = 11872;
                var rct = document.createElement('script');
                    rct.type = 'text/javascript';
                    rct.async = true;
                    rct.src = (document.location.protocol === 'https:' ? 'https:' : 'http:') + '//ads.rubiconproject.com/header/' + account_id + '.js';
                var node = document.getElementsByTagName('script')[0];
                    node.parentNode.appendChild(rct);
            })();

            // Tell Clarity not to load Rubicon
            CLARITY.push({
                use: ['header'],
                run: function(header) {
                    header.skipJsInject('rubicon');
                }
            });
        </script>
<script>
                CLARITY.push({
                    use: ['header'],
                    run: function(header) {
                                                    var slotData = [
                                                                    ["leaderboard_bottom_lazy_1", "/6419/spin/article_page/leaderboard_bottom_lazy", [[728,90],[970,250],[970,90]], "leaderboard_bottom_lazy", false, 0],,                                                                    ["leaderboard_top_1", "/6419/spin/article_page/leaderboard_top", [[728,90],[970,250],[970,90]], "leaderboard_top", false, 0],,                                                                    ["medrec_bottom_lazy_1", "/6419/spin/article_page/medrec_bottom_lazy", [[300,250],[300,600]], "medrec_bottom_lazy", false, 0],,                                                                    ["medrec_top_1", "/6419/spin/article_page/medrec_top", [[300,250],[300,600]], "medrec_top", false, 0],                                                            ];

                            // Add header slots then run,
                            // any slots added after initial run will be processed differently
                            for(var i=0; i<slotData.length; i++) {
                                header.addHeaderSlot.apply(header, slotData[i]);
                            }
                        
                        header.run({"a9":{"account_id":3125,"positions":["leaderboard_top","leaderboard_bottom_lazy","medrec_top","medrec_bottom_lazy"]},"facebook":{"placementIds":{"^leaderboard_(top_)?[0-9]+":"1025146464321968_1025216947648253","^medrec_(bottom_)?lazy_[0-9]+":"1025146464321968_1025217830981498","^medrec_top_[0-9]+":"1025146464321968_1025217387648209"}},"moat":true,"openx":{"network_code":"6419-SPIN","positions":["leaderboard_top","leaderboard_bottom_lazy","medrec_top","medrec_bottom_lazy"]},"rubicon":{"account_id":11872,"positions":["leaderboard_top","leaderboard_bottom_lazy","medrec_top","medrec_bottom_lazy"]}});
                    }
                });
            </script> <script>
    if("I11C" in window && I11C.Morph == 1){
        window.CLARITY.push({
            use: ["instart"], 
            run: function(instart) { 
                instart.run({
                    'unblocked_ads': ["leaderboard_top","medrec_top","medrec_bottom_lazy"]
                });
            }
        });
        window.CLARITY.push({use: ["ads"],run: function(Ads) { Ads.zone = 'unblocked'; }});
    }
</script>

<meta name="description" content="Kanye West was the musical guest on tonight's episode of Saturday Night Live. In his second performance of the night, Kanye joined the stage with Teyana Taylor" />
<link rel="canonical" href="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" />
<meta property="og:title" content="Kanye West Joins Teyana Taylor in &#039;SNL&#039; Performance: Watch" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" />
<meta property="og:image" content="https://static.spin.com/files/2018/09/GettyImages-459984348-1538283958-1024x683.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="683" />
<meta property="og:site_name" content="Spin" />
<meta property="og:description" content="Kanye West was the musical guest on tonight&#039;s episode of Saturday Night Live. In his second performance of the night, Kanye joined the stage with Teyana Taylor to premiere a new song called &quot;We Got Love.&quot; The song, which leaked earlier this summer, also includes a voice memo from Lauryn Hill, which Taylor has hinted at on Twitter. Earlier in the night, he performed his recent hit &quot;I Love It&quot; with Lil Pump. Watch a clip of the performance below.  New song by #KanyeWest and #TeyanaTaylor on #SNL pic.twitter.com/muo0kt45L0 — Carl Kelly (@CarlKellyDMV) September 30, 2018" />
<meta property="article:published_time" content="2018-09-30T01:18:16Z" />
<meta property="article:modified_time" content="2018-09-30T01:18:16Z" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Kanye West Joins Teyana Taylor in &#039;SNL&#039; Performance: Watch" />
<meta name="twitter:description" content="Kanye West was the musical guest on tonight&#039;s episode of Saturday Night Live. In his second performance of the night, Kanye joined the stage with Teyana Taylor to premiere a new song called &quot;We Got Love.&quot; The song, which leaked earlier this summer, also includes a voice memo from Lauryn Hill, which Taylor has hinted at on Twitter. Earlier in the night, he performed his recent hit &quot;I Love It&quot; with Lil Pump. Watch a clip of the performance below.  New song by #KanyeWest and #TeyanaTaylor on #SNL pic.twitter.com/muo0kt45L0 — Carl Kelly (@CarlKellyDMV) September 30, 2018" />
<meta name="twitter:image" content="https://static.spin.com/files/2018/09/GettyImages-459984348-1538283958-1024x683.jpg" />
<meta itemprop="image" content="https://static.spin.com/files/2018/09/GettyImages-459984348-1538283958-1024x683.jpg" />

<link rel='dns-prefetch' href='//assets.spin.com' />
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SPIN &raquo; Watch Kanye West and Teyana Taylor Perform &#8220;We Got Love&#8221; on SNL Comments Feed" href="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/feed/" />
<link rel='stylesheet' id='mobile-zoom-css' href='https://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/css/vendor/mobile-zoom.css?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09' type='text/css' media='all' />
<link rel='stylesheet' id='pi-gallery-css-css' href='https://assets.spin.com/wp-content/plugins/wp-pi-gallery/css/style.css?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09' type='text/css' media='all' />
<link rel='stylesheet' id='icon-styles-css' href='https://www.spin.com/wp-content/themes/wp-theme-base/assets/css/icons.css?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://www.spin.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://www.spin.com/wp/wp-includes/js/underscore.min.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-widgets/js/ajax-widgets.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pgm_sailthru_vars = {"st_source":"web-spin-article"};
/* ]]> */
</script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-newsletter/js/sailthru.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/jquery.lazyloadxt.extra.min.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyloadxt.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyoEmbeds.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<link rel='https://api.w.org/' href='https://www.spin.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.spin.com/wp/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.spin.com/wp/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Watch Kanye West and Lil Pump Perform &#8220;I Love It&#8221; in Water Bottle Costumes on SNL' href='https://www.spin.com/2018/09/kanye-west-lil-pump-i-love-it-snl-performance/' />
<link rel='next' title='Watch Kanye West Perform &#8220;Ghost Town,&#8221; Talk Trump and Presidential Run in SNL Post-Show Speech' href='https://www.spin.com/2018/09/kanye-west-post-snl-speech-trump-presidential-run-ghost-town-performance-watch/' />
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='https://www.spin.com/?p=305524' />
<link rel="alternate" type="application/json+oembed" href="https://www.spin.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.spin.com%2F2018%2F09%2Fkanye-west-teyana-taylor-snl-performance-watch%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.spin.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.spin.com%2F2018%2F09%2Fkanye-west-teyana-taylor-snl-performance-watch%2F&#038;format=xml" />
<meta property="fb:pages" content="14106370407" /><script>
    var ajax_url = 'https\x3A\x2F\x2Fwww.spin.com\x2Fajax';
</script><link rel="amphtml" href="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch?amp=1" />
<link href='https://fonts.googleapis.com/css?family=Vollkorn:400italic,700italic,400,700' rel='stylesheet' type='text/css'>
</head>
<body class="post-template-default single single-post postid-305524 single-format-image">

<noscript>
                    <iframe
                            src="//www.googletagmanager.com/ns.html?id=GTM-N8C7Q9"
                            height="0" width="0" style="display:none;visibility:hidden"></iframe>
                </noscript>
<script>
                    dataLayer = [{"postId":305524,"pagetype":"article-page","author":"Rob Arcand","category":"news","publishedDate":"2018093001","parentTag":"none","tags":"Kanye West, Teyana Taylor"}];
                                        (function (w, d, s, l, i) {
                        w[l] = w[l] || [];
                        w[l].push({
                            'gtm.start': new Date().getTime(), event: 'gtm.js'
                        });
                        var f = d.getElementsByTagName(s)[0],
                            j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
                        j.async = true;
                        j.src =
                            '//www.googletagmanager.com/gtm.js?id=' + i + dl + '';
                        f.parentNode.insertBefore(j, f);
                    })(window, document, 'script', 'dataLayer', 'GTM-N8C7Q9');</script>

<div id="menu" class="navbar navbar-default navbar-fixed-top " role="navigation">
<div class="container">
<div class="inner-nav-holder">
<div class="collapse navbar-collapse">
<ul class="main-nav nav navbar-nav">
<li class="logo">
<div class="navbar-header">
<a href="/" class="navbar-brand" id="logo">
<img src="https://assets.spin.com/wp-content/themes/spin/assets/images/spin-logo.svg" alt="" width="140" height="66">
</a>
</div>
</li>
<li class="  ">
<a href="https://www.spin.com/news/">
News
</a>
</li>
<li class="  ">
<a href="https://www.spin.com/new-music/">
New Music
</a>
</li>
<li class="  ">
<a href="https://www.spin.com/features/">
Features
</a>
</li>
<li class="  ">
<a href="https://www.spin.com/lists/">
Lists
</a>
</li>
<li class="  ">
<a href="https://www.spin.com/archives/">
The Archives
</a>
</li>
<li class="  dt-item">
<a href="https://www.spin.com/death-and-taxes/">
death and taxes
</a>
</li>
</ul>
<div class="social-and-search">
<div class="search">
<form role="search" action="/" method="GET" id="header-search">
<div class="query-holder">
<input type="text" name="s" placeholder="SEARCH" autocomplete="off">
</div>
<span class="search-submit"></span>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="social-block">
<ul class="social-links">
<li>
<a class="icon-facebook" href="https://www.facebook.com/SPIN" target="_blank"></a>
</li>
<li>
<a class="icon-twitter" href="https://www.twitter.com/spin" target="_blank"></a>
</li>
<li>
<a class="icon-instagram" href="https://www.instagram.com/SpinMagazine" target="_blank"></a>
</li>
<li class="more-social-icons">
<span class="icon-plus"></span>
<ul class="extra-1">
<li>
<a class="icon-google_plus" href="https://plus.google.com/+spinmagazine/posts" target="_blank"></a>
</li>
</ul>
</li>
</ul>
</div>
</div>
<div class="social-holder sticky-header">
<div class="social-icons">
<div class="social-container">
<div class="logo"><a href="/"></a></div>
<div class="title">Share < br />this article:</div>
<div class="email sharrre" data-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-short-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-utm-source="share-email" data-text="Watch Kanye West and Teyana Taylor Perform &quot;We Got Love&quot; on &lt;i&gt;SNL&lt;/i&gt;" data-title="Email"></div>
<div class="facebook sharrre" data-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-short-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-utm-source="share-fb" data-text="Watch Kanye West and Teyana Taylor Perform &quot;We Got Love&quot; on &lt;i&gt;SNL&lt;/i&gt;" data-title="Share"></div>
<div class="twitter sharrre" data-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-short-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-utm-source="share-tw" data-text="Watch Kanye West and Teyana Taylor Perform &quot;We Got Love&quot; on &lt;i&gt;SNL&lt;/i&gt;" data-title="Tweet"></div>
<div class="reddit sharrre" data-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-short-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-utm-source="share-red" data-text="Watch Kanye West and Teyana Taylor Perform &quot;We Got Love&quot; on &lt;i&gt;SNL&lt;/i&gt;" data-title="Reddit"></div>
</div>
</div> </div>
<div class="container ad-container">
<div class="leaderboard_top-placeholder">
<div class="leaderboard_top-holder">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class="ad_desktop leaderboard" data-position='leaderboard_top' data-sizes='[[728,91],[970,251],[970,91],[728,90],[970,250],[970,90]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='1' style="min-width: 728px; min-height: 90px; box-sizing: content-box;">
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="container main-container">
<div class="row">
<div class="sidebar-bg"></div>
<div class="col-sm-8 left-col">
<div class="article-body" itemScope itemType="https://schema.org/Article">
<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<meta itemprop="name" content="Spin">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<link itemprop="url" content="https://www.spin.com/wp-content/themes/spin/assets/images/logo.png">
<meta itemprop="width" content="470">
<meta itemprop="height" content="225">
</div>
</div>
<div class="article-title">
<h2 class="category">
<a href="https://www.spin.com/news/">
News <span>\</span>
</a>
</h2>
<h1 itemprop="headline" class="title">
Watch Kanye West and Teyana Taylor Perform &#8220;We Got Love&#8221; on <i>SNL</i>
</h1>
<h2 class="subtitle"> </h2>
</div>
<div class="author">
<span itemprop="author"><a href="https://www.spin.com/author/rob_arcand/">Rob Arcand</a></span>
<span class="date" itemprop="datePublished" content="2018-09-30T01:18:16+00:00">// September 30, 2018</span>
</div>
<div class="social-holder">
<div class="social-icons post-header">
<div class="social-container">
<div class="logo"><a href="/"></a></div>
<div class="title">Share < br />this article:</div>
<div class="email sharrre" data-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-short-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-utm-source="share-email" data-text="Watch Kanye West and Teyana Taylor Perform &quot;We Got Love&quot; on &lt;i&gt;SNL&lt;/i&gt;" data-title="Email"></div>
<div class="facebook sharrre" data-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-short-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-utm-source="share-fb" data-text="Watch Kanye West and Teyana Taylor Perform &quot;We Got Love&quot; on &lt;i&gt;SNL&lt;/i&gt;" data-title="Share"></div>
<div class="twitter sharrre" data-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-short-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-utm-source="share-tw" data-text="Watch Kanye West and Teyana Taylor Perform &quot;We Got Love&quot; on &lt;i&gt;SNL&lt;/i&gt;" data-title="Tweet"></div>
<div class="reddit sharrre" data-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-short-url="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/" data-utm-source="share-red" data-text="Watch Kanye West and Teyana Taylor Perform &quot;We Got Love&quot; on &lt;i&gt;SNL&lt;/i&gt;" data-title="Reddit"></div>
</div>
</div> </div>
<div class="featured-embed-holder format-image">
<div class="article-image-holder">
<div class="mainembed photoembed mainembed-article-embed/large align-center">
<div class="img-wrap">
<img itemprop="image" src="https://static.spin.com/files/2018/09/GettyImages-459984348-1538283958-640x427.jpg" alt="kanye-west-teyana-taylor-snl-performance-watch" width="640" height="427">
</div>
<div class="credit-wrapper">
<div class="credit"><small>CREDIT:</small> Johnny Nunez/Getty Images</div>
</div>
</div>
</div>
</div>
<div class="article-content-holder">
<link itemprop="mainEntityOfPage" href="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/">
<meta itemprop="dateModified" content="2018-09-30T01:18:16+00:00">
<div itemprop="articleBody" class="single-content-holder">
<div class="article-content clearfix">
<p><a href="http://spin.com/tag/Kanye-West/" target="_blank" rel="noopener noreferrer">Kanye West</a> was the musical guest on tonight&#8217;s episode of <i>Saturday Night Live</i>. In his second performance of the night, Kanye joined the stage with <a href="http://spin.com/tag/Teyana-Taylor/" target="_blank" rel="noopener noreferrer">Teyana Taylor</a> to premiere a new song called &#8220;<a href="https://www.stereogum.com/2016653/kanye-west-teyana-taylor-snl/video/" target="_blank" rel="noopener noreferrer">We Got Love.</a>&#8221; The song, which <a href="https://www.hotnewhiphop.com/teyana-taylors-we-got-love-leaks-with-vocals-from-lauryn-hill-news.54777.html" target="_blank" rel="noopener noreferrer">leaked earlier this summer</a>, also includes a voice memo from <a href="http://spin.com/tag/Lauryn-Hill/" target="_blank" rel="noopener noreferrer">Lauryn Hill</a>, which Taylor has <a href="https://twitter.com/TEYANATAYLOR/status/1009675490439774209?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1009675490439774209&amp;ref_url=https://www.hotnewhiphop.com/teyana-taylors-we-got-love-leaks-with-vocals-from-lauryn-hill-news.54777.html" target="_blank" rel="noopener noreferrer">hinted at</a> on Twitter. Earlier in the night, he <a href="https://www.spin.com/2018/09/kanye-west-lil-pump-i-love-it-snl-performance/" target="_blank" rel="noopener noreferrer">performed his recent hit &#8220;I Love It&#8221;</a> with Lil Pump. Watch a clip of the performance below.</p>
<blockquote class="twitter-tweet" data-lang="en">
<p dir="ltr" lang="en">New song by <a href="https://twitter.com/hashtag/KanyeWest?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener noreferrer">#KanyeWest</a> and <a href="https://twitter.com/hashtag/TeyanaTaylor?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener noreferrer">#TeyanaTaylor</a> on <a href="https://twitter.com/hashtag/SNL?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener noreferrer">#SNL</a> <a href="https://t.co/muo0kt45L0" target="_blank" rel="noopener noreferrer">pic.twitter.com/muo0kt45L0</a></p>
<p>— Carl Kelly (@CarlKellyDMV) <a href="https://twitter.com/CarlKellyDMV/status/1046261282549235713?ref_src=twsrc%5Etfw" target="_blank" rel="noopener noreferrer">September 30, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<div class="author-footer">
<div class="inner">
<div class="avatar">
<a href="https://www.spin.com/author/rob_arcand/"><img alt='' src='https://secure.gravatar.com/avatar/a1f290e88fffc864bf313166a6bb0ffd?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a1f290e88fffc864bf313166a6bb0ffd?s=120&amp;d=mm&amp;r=g 2x' class='avatar avatar-60 photo' /></a>
</div>
<div class="text">
<div class="name">
<a href="https://www.spin.com/author/rob_arcand/">Rob Arcand</a>
</div>
<div class="list">
<ul>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="row tags-and-comments">
<div class="col-sm-9">
<div itemprop="keywords" class="tags">
<strong>Tags:</strong>
<a href="https://www.spin.com/tag/kanye-west/">Kanye West</a>, <a href="https://www.spin.com/tag/teyana-taylor/">Teyana Taylor</a> </div>
</div>
<div class="col-sm-3">
<div itemprop="comment" class="comments right">
<a href="https://www.spin.com/2018/09/kanye-west-teyana-taylor-snl-performance-watch/#respond" data-disqus-identifier="invalid-id-to-prevent-link-overwrite"><span class="count disqus-comment-count" data-disqus-identifier="305524 https://www.spin.com/?p=305524"></span><span class="article-comment-bubble"></span></a>
</div>
</div>
</div>
</div>
</div>
<hr>
<div class="zergnet-holder">
<div class="zergnet-widget" id="zergnet-widget-33039" data-zergnet-id="33039"></div>
</div>
<div class="link-exchanges">
<div class="recommended-module ">
<div class="title-holder">
<h2>Recommended for you <span class="red">\</span></h2>
</div>
<div class="row">
</div>
<div class="row">
<div class="col-sm-4">
<div class="image-holder">
<a href="https://www.spin.com/2018/09/kanye-west-post-snl-speech-trump-presidential-run-ghost-town-performance-watch/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
<img src="https://static.spin.com/files/2018/09/GettyImages-1042541672-1-1538319131-191x127.jpg" width="191" height="127" alt="Watch Kanye West Perform &#8220;Ghost Town,&#8221; Talk Trump and Presidential Run in <i>SNL</i> Post-Show Speech">
</a>
</div>
<div class="preview-holder">
<a href="https://www.spin.com/2018/09/kanye-west-post-snl-speech-trump-presidential-run-ghost-town-performance-watch/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
<h3>
Watch Kanye West Perform &#8220;Ghost Town,&#8221; Talk Trump and Presidential Run in <i>SNL</i> Post-Show Speech
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="https://www.spin.com/2018/09/kanye-west-lil-pump-i-love-it-snl-performance/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
<img src="https://static.spin.com/files/2018/09/Kanye-SNL-1538281232-640x349-1538282908-191x127.jpg" width="191" height="127" alt="Watch Kanye West and Lil Pump Perform &#8220;I Love It&#8221; in Water Bottle Costumes on <i>SNL</i>">
</a>
</div>
<div class="preview-holder">
<a href="https://www.spin.com/2018/09/kanye-west-lil-pump-i-love-it-snl-performance/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
<h3>
Watch Kanye West and Lil Pump Perform &#8220;I Love It&#8221; in Water Bottle Costumes on <i>SNL</i>
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="https://www.spin.com/2018/09/kanye-west-to-bring-out-kid-cudi-lil-pump-teyana-taylor-070-shake-snl-performance-report/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
<img src="https://static.spin.com/files/2018/09/GettyImages-983141804-1538251905-191x127.jpg" width="191" height="127" alt="Report: Kanye West to Bring Out Kid Cudi, Lil Pump, Teyana Taylor, and 070 Shake on <i>SNL</i>">
</a>
</div>
<div class="preview-holder">
<a href="https://www.spin.com/2018/09/kanye-west-to-bring-out-kid-cudi-lil-pump-teyana-taylor-070-shake-snl-performance-report/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
<h3>
Report: Kanye West to Bring Out Kid Cudi, Lil Pump, Teyana Taylor, and 070 Shake on <i>SNL</i>
</h3>
</a>
</div>
</div>
</div>
<div class="row">
<div class="col-sm-4">
<div class="image-holder">
<a href="https://www.spin.com/2018/09/kanye-west-alex-jones-trump-matrix-breakers-quote-the-fader/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
<img src="https://static.spin.com/files/2018/09/the-fader-kanye-alex-jones-deleted-1538155905-191x127.jpg" width="191" height="127" alt="<i>The Fader</i> Deletes Trump, Alex Jones Quotes From Report on Kanye West&#8217;s Office Visit">
</a>
</div>
<div class="preview-holder">
<a href="https://www.spin.com/2018/09/kanye-west-alex-jones-trump-matrix-breakers-quote-the-fader/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
<h3>
<i>The Fader</i> Deletes Trump, Alex Jones Quotes From Report on Kanye West&#8217;s Office Visit
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="https://www.spin.com/2018/09/kanye-west-snl-ariana-grande-dropped-out/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
<img src="https://static.spin.com/files/2018/09/kanye-west-ariana-grande-snl-1538143251-191x127.jpg" width="191" height="127" alt="Kanye West Is Performing on <i>SNL</i>&#8217;s Season Premiere Because Ariana Grande Dropped Out">
</a>
</div>
<div class="preview-holder">
<a href="https://www.spin.com/2018/09/kanye-west-snl-ariana-grande-dropped-out/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
<h3>
Kanye West Is Performing on <i>SNL</i>&#8217;s Season Premiere Because Ariana Grande Dropped Out
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="https://www.spin.com/2018/09/kanye-west-the-fader-slavery-6ix9ine/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
<img src="https://static.spin.com/files/2018/09/kanye-west-fader-crazy-1538074339-191x127.jpg" width="191" height="127" alt="Kanye Defends Alex Jones, Louis CK, Donald Trump While Wearing Kaepernick T-Shirt">
</a>
</div>
<div class="preview-holder">
<a href="https://www.spin.com/2018/09/kanye-west-the-fader-slavery-6ix9ine/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
<h3>
Kanye Defends Alex Jones, Louis CK, Donald Trump While Wearing Kaepernick T-Shirt
</h3>
</a>
</div>
</div>
</div>
</div>
</div>
<div id="amazon-widget"></div>
<script type="text/javascript">
                        additional_search = "above $20";
                        amzn_assoc_ad_mode = "search";
                        amzn_assoc_ad_type = "smart";
                        amzn_assoc_div_name = "amazon-widget";
                        amzn_assoc_marketplace = "amazon";
                        amzn_assoc_placement = "smart1";
                        amzn_assoc_region = "US";
                        amzn_assoc_rows = "1";
                        amzn_assoc_search_bar = "false";
                        amzn_assoc_title = "Available at Amazon";
                        amzn_assoc_tracking_id = "spin049-20";
                        categories = "Array";
                    </script>
<script type="text/javascript" src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&source=ac"></script>
</div>
<div class="col-sm-4 sidebar">
<div class="sm-widget sm-widget-ad-holder"><div class="sm-widget-ad"> <div class="ad_desktop" data-position='medrec_top' data-sizes='[[300,251],[300,601],[300,250],[300,600]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='2' style="min-width: 300px; min-height: 250px; box-sizing: content-box;">
</div>
</div></div><div class="sidebar-module ">
<div class="feed feed-tile"><div class="title-holder clearfix"><div class="title left"><a href="https://www.spin.com/reviews/"><h2>
Reviews
<span class="red">\</span></h2></a></div><div class="see-all right"><a href="https://www.spin.com/reviews/">Read More &raquo;</a></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="https://www.spin.com/2018/09/noname-room-25-review/" class=" ga-product-impression" data-list-name="Reviews - article-page" data-list-position="1"><img src="https://static.spin.com/files/2018/09/Screen-Shot-2018-09-27-at-1.53.59-PM-1538070858-145x145.png" alt="Noname&#8217;s &#8216;Room 25&#8242; Is One of the Most Quietly Powerful Rap Albums of 2018"></a></div><div class="preview-holder"><a href="https://www.spin.com/2018/09/noname-room-25-review/" class="title-link  ga-product-impression" data-list-name="Reviews - article-page" data-list-position="1">Noname&#8217;s &#8216;Room 25&#8242; Is One of the Most Quietly Powerful Rap Albums of 2018</a></div><div class="overlay"></div></div><div class="post"><div class="image-holder"><a href="https://www.spin.com/2018/09/beak-third-album-review/" class=" ga-product-impression" data-list-name="Reviews - article-page" data-list-position="2"><img src="https://static.spin.com/files/2018/09/a1291098534_10-1537993980-145x145.jpg" alt="Beak> Approach the Limits of Their Steely Minimalism on <i>>>></i>"></a></div><div class="preview-holder"><a href="https://www.spin.com/2018/09/beak-third-album-review/" class="title-link  ga-product-impression" data-list-name="Reviews - article-page" data-list-position="2">Beak> Approach the Limits of Their Steely Minimalism on <i>>>></i></a></div><div class="overlay"></div></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="https://www.spin.com/2018/09/prince-piano-and-a-microphone-1983-review/" class=" ga-product-impression" data-list-name="Reviews - article-page" data-list-position="3"><img src="https://static.spin.com/files/2018/09/prince-piano-and-a-microphone-1537819559-145x145.jpg" alt="Prince&#8217;s Playful &#8216;Piano &#038; a Microphone 1983&#8242; Is an Intimate Peek Into a Master&#8217;s Process"></a></div><div class="preview-holder"><a href="https://www.spin.com/2018/09/prince-piano-and-a-microphone-1983-review/" class="title-link  ga-product-impression" data-list-name="Reviews - article-page" data-list-position="3">Prince&#8217;s Playful &#8216;Piano &#038; a Microphone 1983&#8242; Is an Intimate Peek Into a Master&#8217;s Process</a></div><div class="overlay"></div></div><div class="post"><div class="image-holder"><a href="https://www.spin.com/2018/09/aphex-twin-collapse-ep-review/" class=" ga-product-impression" data-list-name="Reviews - article-page" data-list-position="4"><img src="https://static.spin.com/files/2018/09/aphex-twin-collapse-1537296821-145x145.jpg" alt="Aphex Twin&#8217;s Surprisingly Ambitious <i>Collapse</i> EP Proves He&#8217;s as Restless As Ever"></a></div><div class="preview-holder"><a href="https://www.spin.com/2018/09/aphex-twin-collapse-ep-review/" class="title-link  ga-product-impression" data-list-name="Reviews - article-page" data-list-position="4">Aphex Twin&#8217;s Surprisingly Ambitious <i>Collapse</i> EP Proves He&#8217;s as Restless As Ever</a></div><div class="overlay"></div></div></div></div></div><div class="sm-widget sm-widget-ad-holder"><div class="sm-widget-ad"> <div class="ad_desktop" data-position='medrec_bottom_lazy' data-sizes='[[300,250],[300,600]]' data-lazy-load='1' data-refresh='1' data-refresh-timer='15' data-swap='' data-load-order='' style="min-width: 300px; min-height: 250px; box-sizing: content-box;">
</div>
</div></div>
</div>
</div>
</div>
<div class="container footer-ad-holder">
<div class="leaderboard-wrapper">
<div class="ad_desktop leaderboard" data-position='leaderboard_bottom_lazy' data-sizes='[[728,90],[970,250],[970,90]]' data-lazy-load='1' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='' style="min-width: 728px; min-height: 90px; box-sizing: content-box;">
</div>
</div>
</div>
<div class="footer-recommended">
<div class="container">
<h3>Editor's Picks</h3>
<div class="row">
<a href="/featured/punk-talks-pinegrove-controversy/">
<div class="post col-sm-4">
<div class="overlay"></div>
<div class="img-wrap">
<img src="https://static.spin.com/files/2018/04/punk-talks-pinegrove-1524260896-313x209.jpg" width="313" height="209" alt="Punk Talks Controversy: Pinegrove, a Mishandled Allegation, and Finding a Path Forward">
</div>
<div class="title">
<div>Punk Talks Controversy: Pinegrove, a Mishandled Allegation, and Finding a Path Forward</div>
</div>
</div>
</a>
<a href="/featured/the-mtv-news-experiment/">
<div class="post col-sm-4">
<div class="overlay"></div>
<div class="img-wrap">
<img src="https://static.spin.com/files/2017/06/MTV_revise2-1498774758-313x209.jpg" width="313" height="209" alt="MTV News: The Good, the Bad, and the Contradictions of an Ill-Fated Experiment">
</div>
<div class="title">
<div>MTV News: The Good, the Bad, and the Contradictions of an Ill-Fated Experiment</div>
</div>
</div>
</a>
<a href="/2017/03/discogs-most-expensive-record-billy-yeager/">
<div class="post col-sm-4">
<div class="overlay"></div>
<div class="img-wrap">
<img src="https://static.spin.com/files/2017/03/Screen-Shot-2017-03-23-at-9.04.22-AM-1490274298-313x209.png" width="313" height="209" alt="The Unbelievable Story of the Most Expensive Record Ever Sold on Discogs">
</div>
<div class="title">
<div>The Unbelievable Story of the Most Expensive Record Ever Sold on Discogs</div>
</div>
</div>
</a>
</div>
</div>
</div>
<footer id="footer">
<div class="container">
<div class="comscore">
<div class="comscore-header clearfix">
<div class="right">
<div class="mobile-site-footer">
</div>
<div class="footer-logo">
<a href="/">
<img src="https://assets.spin.com/wp-content/themes/spin/assets/images/spin-logo.svg" alt="" width="92" height="43">
</a>
</div>
</div>
<div class="left">
<ul class="social-links">
<li>
<a href="https://www.facebook.com/SPIN" target="_blank">
<div class="social-icon square facebook">
<span class="icon-facebook"></span>
</div>
</a>
</li>
<li>
<a href="https://www.twitter.com/spin" target="_blank">
<div class="social-icon square twitter">
<span class="icon-twitter"></span>
</div>
</a>
</li>
<li>
<a href="https://www.instagram.com/SpinMagazine" target="_blank">
<div class="social-icon square instagram">
<span class="icon-instagram"></span>
</div>
</a>
</li>
</ul>
<div class="menu">
<a href="https://www.spin.com/news" alt="news">NEWS</a>
<a href="https://www.spin.com/new-music" alt="new music">NEW MUSIC</a>
<a href="https://www.spin.com/culture" alt="culture">CULTURE</a>
<a href="https://www.spin.com/features" alt="features">FEATURES</a>
<a href="https://www.spin.com/lists" alt="lists">LISTS</a>
<a href="https://www.spin.com/archives" alt="the archives">THE ARCHIVES</a>
<a href="/cdn-cgi/l/email-protection#86f2eff6f5c6f5f6efe8a8e5e9eb" alt="contact us">CONTACT US</a>
</div>
<span class="site-name">SPIN</span>.com is a member of Billboard Music, a division of Billboard-Hollywood Reporter Media Group.
<div class="comscore-header-links">
<a class="comscore--link comscore--header-link" href="/about">About <span class="comscore--bold">Spin</span></a>
<a class="comscore--link comscore--header-link" href="/privacy-policy" target="_blank">Privacy Policy</a>
<a class="comscore--link comscore--header-link" href="/about-our-ads" target="_blank" class="cs_aboutBug">
<img src="https://lib.pgmcdn.com/choices/collisionadmarkerwht.png" alt="adChoices" class="comscore--img">
</a>
<a class="comscore--link" href="/copyright" target="_blank">Copyright</a>
</div>
</div>
</div>
<div class="comscore--body">
<a class="comscore--link" href="//www.billboard.com" target="_blank">Billboard</a> |
<a class="comscore--link" href="//www.hollywoodreporter.com/" target="_blank">The Hollywood Reporter</a> |
<a class="comscore--link" href="//www.spin.com/" target="_blank">SPIN</a> |
<a class="comscore--link" href="//www.vibe.com/" target="_blank">VIBE</a> |
<a class="comscore--link" href="//www.stereogum.com/" target="_blank">Stereogum</a>
</div>
</div>
</div>
</footer>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
        // Asynchronous Loading
        var script = document.createElement("script");
        script.src = script.src = document.location.protocol + '//platform.twitter.com/widgets.js';
        script.async = true;
        document.getElementsByTagName("body")[0].appendChild(script);
    </script>
<script id="ad_slot" type="text/template">
            <div class="ad_desktop" data-sizes="[[160,600],[300,250],[300,600]]" data-position="300c"></div>
        </script>
<div id="hidden_div" class="hidden"></div>
<div class="ad_desktop" data-position='zergnet' data-sizes='[[4,4]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='' style="min-width: 4px; min-height: 4px; box-sizing: content-box;">
</div>
<div id="ad_native_instream" class="ad_desktop" data-sizes="[2,2]" data-position="native_instream_lazy"></div>
<div id="ad_native_rightrail" class="ad_desktop" data-sizes="[2,2]" data-position="native_detail_lazy"></div><script type="text/html" id="sc_interrupter_template">
<div class="post row wp-pi-sponsored-content-interrupter">
    <div class="posts-holder"> 
                    <div class="interrupter-post"> 
            <div class="image-holder"> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <img src="<% if(typeof post_images == "object") { print(post_images.feed.split) } %>"> 
            </a> 
            <div class="text-overlay">
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>>
                    <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                </a>
            </div> 
        </div> 
        <div class="preview-holder"> 
                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                <div class="shared-by">
                    <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                </div>
            <% } %>    
                <h2> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <% if(typeof post_title !== "undefined") { print(post_title) } %>
            </a> 
        </h2> 
        <% if(typeof sponsor_image !== "undefined") { %>
            <div class="sponsor"> 
                                <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %>

                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                    <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                </a> 
                
                                <% if((typeof show_sponsor === "undefined" || show_sponsor )
                        && typeof sponsor_name !== "undefined") { %>
                    <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %>
                    <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                        <span>
                            <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                        </span>
                    </a> 
                <% } %>
            </div> 
        <% } %>
                <div class="preview"> 
            <% if(typeof post_preview !== "undefined") { print(post_preview) } %>
        </div> 
            </div> 
</div>            </div> 
</div>
</script><script type="text/html" id="sc_interrupter_template_sidebar">
<div class="sidebar-module wp-pi-sponsored-content-interrupter"> 
    <div class="title-holder clearfix"> 
            <div class="title left"> 
        <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>">
            <h3>
                <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                <span class="red">\</span>
            </h3>
        </a>
    </div> 
    </div> 
    <div class="posts-holder"> 
        <div class="interrupter-post"> 
            <div class="image-holder"> 
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>> 
                    <img src="<% if(typeof post_images == "object") { print(post_images.sidebar) } %>">
                </a> 
            </div> 
            <div class="preview-holder"> 
                                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                        <div class="shared-by">
                            <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                        </div>
                    <% } %>    
                                <h2> 
                    <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>>
                        <% if(typeof post_title !== "undefined") { print(post_title) } %>
                    </a> 
                </h2> 
                <% if(typeof sponsor_image !== "undefined") { %>
                     
                        <div class="sponsor">
                                                        <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                            
                            <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                            </a> 
                            <% if((typeof show_sponsor === "undefined" || show_sponsor)
                                    && typeof sponsor_name !== "undefined") { %>
                                <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                    <span>
                                        <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                                    </span>
                                </a> 
                            <% } %>
                        </div> 
                     
                <% } %>
            </div> 
        </div> 
    </div> 
</div>
</script> <div class="ad_desktop" data-position='out_of_page' data-sizes='[[1,1]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='3' data-out-of-page='true' style="display: none;">
</div>
<script>CLARITY.push({use:['ads','header','doubleunderscore','logger'],run:function(Ads,Header,__,logger){var $slots=$('[data-position="medrec_lazy"],[data-position="leaderboard_lazy"]');$slots.each(function(i){var $this=$(this),id=$this.attr('id');var addLazyLoadedSlots=function(){try{var id=$this.attr('id'),ad=Ads.getById(id);Header.addHeaderSlot(id,ad._getAdUnitPath(),ad.options.sizes,ad.options.position);}catch(e){logger.log("addLazyLoadedSlots failed with error : "+e,"error");}};if(id){addLazyLoadedSlots();}else{$this.on('clarity:create-ad',function(){addLazyLoadedSlots();});}});}});</script>
<script>CLARITY.push({use:['ads'],run:function(Ads){Ads.site_code="spin";if(!Ads.zone){Ads.zone="article_page";}
var keywords=[];keywords.push({keywords:"",keyvalues:"post_id=305524",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"category=news",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"tags=kanye-west,teyana-taylor",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"domain=www.spin.com",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"url=d5f1f164",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"pagetype=article_page",paths:"",positions:"all"});Ads.keywords=keywords;Ads.optionDefaults=Ads.optionDefaults||{};Ads.autoPopulate();}});</script> <script type="text/html" id="pe_zoom_overlay">
        <div class="pe-zoom-overlay scroll-<%= scroll_dir %>">
            <div class="image-holder">
                <img itemprop="image"
                     src="<%= img_src %>">
            </div>
            <div class="pe-zoom-close-x"></div>
        </div>
    </script><link rel='stylesheet' id='ad-css-css' href='https://assets.spin.com/wp-content/plugins/wp-pi-clarity/css/clarity.css?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09' type='text/css' media='all' />
<link rel='stylesheet' id='zergnet-article-css-css' href='https://assets.spin.com/wp-content/plugins/wp-pi-zergnet/css/article.css?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var mobileDetect = {"isMobile":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-mobile-theme/js/mobile_detect.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/img-touch-canvas.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.spin.com/wp/wp-includes/js/wp-util.min.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/mobile-zoom.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-sponsored-content/js/interrupter/interrupter.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/js/bootstrap.min.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/lodash.2.4.1.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/themes/wp-theme-base/assets/js/all.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/themes/spin/assets/js/all.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://www.spin.com/wp/wp-includes/js/wp-embed.min.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-sharrre/js/jquery.sharrre.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-sharrre/js/sharrre-init.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-clarity/js/sticky.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
<script type='text/javascript' src='https://assets.spin.com/wp-content/plugins/wp-pi-zergnet/js/zergnet.js?ver=e5e5b2b7a4b3a08f6566bb975e6906b2d80cde09'></script>
</body>
</html>