<!doctype html>
<html>
    <head>
                            <meta charset="UTF-8" />
            <title>The Weeknd Shares New Video for 'Too Late' | SPIN</title>
        
        <link rel="icon" href="/favicon.ico" />

        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <meta name="viewport" content="width=device-width">

        <link rel="alternate" type="application/rss+xml" title="RSS"
              href="https://www.spin.com/feed">

        <link rel="stylesheet" href="https://www.spin.com/wp-content/themes/spin/assets/css/style.css?0.0.5" type="text/css" media="screen" />

        <script type="text/javascript" src="/wp-content/plugins/wp-pi-spinmedia-core/js/queue-scripts.js?_v=f640a83187040d1114d9eda3f808ba9e" charset="UTF-8"></script><script type="text/javascript">
                        window.blockScripts = false;
                        window.onetrustURL = "";
                    </script>
<!-- All in One SEO Pack 2.3.11 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] -->
<meta name="description"  content="It's latest to emerge from his 'After Hours' album that was released earlier this year" />

<link rel="canonical" href="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" />
<meta property="og:title" content="The Weeknd Shares &#039;Too Late&#039; Video" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" />
<meta property="og:image" content="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/10/USUMV2001679-1603394226-1024x594.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="594" />
<meta property="og:site_name" content="Spin" />
<meta property="og:description" content="It&#039;s latest to emerge from his &#039;After Hours&#039; album that was released earlier this year" />
<meta property="article:published_time" content="2020-10-22T15:05:00Z" />
<meta property="article:modified_time" content="2020-10-22T15:17:52Z" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="The Weeknd Shares &#039;Too Late&#039; Video" />
<meta name="twitter:description" content="It&#039;s latest to emerge from his &#039;After Hours&#039; album that was released earlier this year" />
<meta name="twitter:image" content="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/10/USUMV2001679-1603394226-1024x594.jpg" />
<meta itemprop="image" content="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/10/USUMV2001679-1603394226-1024x594.jpg" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SPIN &raquo; The Weeknd Finds a New Body in Bloody &#8216;Too Late&#8217; Video Comments Feed" href="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/feed/" />
<link rel='stylesheet' id='mobile-zoom-css'  href='https://www.spin.com/wp-content/plugins/wp-pi-spinmedia-core/css/vendor/mobile-zoom.css?ver=0.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='pi-gallery-css-css'  href='https://www.spin.com/wp-content/plugins/wp-pi-gallery/css/style.css?ver=0.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='icon-styles-css'  href='https://www.spin.com/wp-content/themes/wp-theme-base/assets/css/icons.css?ver=0.0.5' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-includes/js/underscore.min.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-spinmedia-widgets/js/ajax-widgets.js?ver=0.0.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pgm_sailthru_vars = {"st_source":"web-spin-article"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-newsletter/js/sailthru.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/jquery.lazyloadxt.extra.min.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyloadxt.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyoEmbeds.js?ver=0.0.5'></script>
<link rel='https://api.w.org/' href='https://www.spin.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.spin.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.spin.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Jack White Buys Busker New Guitar After Jerk Smashes Old One' href='https://www.spin.com/2020/10/jack-white-buys-busker-new-guitar-after-jerk-smashes-old-one/' />
<link rel='shortlink' href='https://www.spin.com/?p=360898' />
<link rel="alternate" type="application/json+oembed" href="https://www.spin.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.spin.com%2F2020%2F10%2Fthe-weeknd-shares-bloody-too-late-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.spin.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.spin.com%2F2020%2F10%2Fthe-weeknd-shares-bloody-too-late-video%2F&#038;format=xml" />
<script>
    var ajax_url = 'https\x3A\x2F\x2Fwww.spin.com\x2Fajax';
</script><link rel="amphtml" href="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video?amp=1" />    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-3473883-1"></script>
    <script>
      window.dataLayer = window.dataLayer || [];
      function gtag(){dataLayer.push(arguments);}
      gtag('js', new Date());

      gtag('config', 'UA-3473883-1');
    </script>
  		<style type="text/css" id="wp-custom-css">
			.sidebar .sm-widget-campaign-monitor{
 background:#000;
}
.sidebar sellwild {
    display: block;
    height: 600px;
    width: 300px;
}
.sellwild-main-title{
 white-space:unset !important;
}
.sellwild-widget a.sellwild-main-link {
    font-size: 18px !important;
}
.sidebar .sellwild-widget{
 height: 600px;
 width: 300px;
 overflow-y: scroll;
}
.sidebar{
 padding-left:10px;
 padding-right:10px;
}
.newsletter-logo {
 margin-bottom: 30px;
 text-align:left;
 padding-left:2px;
}
.sm-widget-campaign-monitor.text-center h1 {
 color: #e61739;
 font-size:30px;
}
.sm-widget-campaign-monitor.text-center h3{
 padding-left:10px;
 padding-right:10px;
 color:#fff;
 font-weight: 400;
 font-size:20px;
	margin-top:24px;
}
.sidebar .sm-widget-campaign-monitor{
 padding:13px 3px 14px 5px;
}
#newsletter-1 {
 padding: 15px;
}
.EMAIL-label{
display:none;
margin-bottom: 1.5em;
}
#newsletter-1 button{
margin: 0 auto;
font-family: "Fakt SemiCondensed", "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 300;
font-size: 19px;
height:45px;
line-height:47px;
	border-radius:0;
width:130px;
	background:#e61739;
}
.sidebar .sm-widget-campaign-monitor .edit-link{
display:none;
}
.sidebar .sm-widget-campaign-monitor .disclaimer, .sidebar .sm-widget-campaign-monitor .disclaimer a{

    color: #929497;
    font-family: "Fakt SemiCondensed", "Helvetica Neue", Helvetica, Arial, sans-serif;
    font-size: 11px !important;
}
.sidebar .sm-widget-campaign-monitor .disclaimer a:hover{
color:#e51937;
}
.EMAIL-label.yikes-mailchimp-field-required input::placeholder {

    font-weight: 400;
    font-family: "Fakt SemiCondensed", "Helvetica Neue", Helvetica, Arial, sans-serif;

}
.sidebar .sm-widget-campaign-monitor .yikes-easy-mc-form input{
padding:8px 7px 5px;
font-weight: 400;
	margin-bottom:15px;
	color:#929497;
 border: 1px solid #fff !important;
border-radius: 0 !important;
}

.email-footer-box {
    display: flex;
	  position:relative;
}
.email-footer-box .edit-link {
    display: none !important;
}
.email-footer-box #newsletter-1 {
    padding: 10px 12px 5px;
}
.spin.modal-content .EMAIL-label.yikes-mailchimp-field-required{
 padding: 47px 64px 25px !important;
}
.footer-logo{
 text-align:right;
}
.left-spin-img img {
width: 55px;
padding-top: 6px;
}
.email-footer-box #yikes-easy-mc-form-1-EMAIL, .email-footer-box .EMAIL-label.yikes-mailchimp-field-required {
    margin-bottom: 0;
}
.email-footer-box input {
    width: 214px !important;
    height: 30px;
	color:#b9b9b9;
	font-size:13px;
}
.email-footer-box {
    background: #000;
    padding: 3px 4px 7px 12px;
    margin-top: 36px;
    border: 1px solid #fff;
}
.email-footer-box input::placeholder {
    color: #b9b9b9;
}
.email-footer-box .yikes-easy-mc-error-message{
 position: absolute;
width:313px;
left: -2px;
bottom: 119px;
}
.email-footer-box .send-update-email{
 color:rgba(216,48,57,.87);
}
.sm-widget-campaign-monitor .yikes-easy-mc-success-message{
 background:#fff !important;
 color:#000 !important;
	opacity:1 !important;
	padding: 8px !important;
	font-family: "Fakt SemiCondensed", "Helvetica Neue", Helvetica, Arial, sans-serif;
font-weight: 500;
}
.bx-viewport {
    height: 506px !important;
}
a.read_more_bx{
 background: red;
 padding: 10px 10px;
}
.spin.modal-content .edit-link{
 display:none;
}
.email-footer-box button {
    height: 10px !important;
    line-height: 1 !important;
    margin-top: 10px !important;
}
.email-footer-box #newsletter-1 {
    padding: 10px 12px 8px;
    margin-bottom: 0;
}
.spin.modal-content .disclaimer, .spin.modal-content .disclaimer a {
    text-align: center;
	color:#fff;
	margin: 25px 0;
	font-family:"Fakt SemiCondensed", "Helvetica Neue", Helvetica, Arial, sans-serif;
	font-weight:400;
}
.spin.modal-content #newsletter-1 button{
 height:auto;
 width:200px;
font-size:25px;
padding-top: 13px;
padding-top: 16px;
line-height: 30px;
}
.spin.modal-content .yikes-easy-mc-form input[type="email"]{
 font-size: 21px;
}
.modal-header .close{
 width: 25px !important;
font-size: 35px;
 background: #000;
 opacity: 1;
 color: #fff;
 position: absolute;
 right: 0;
 top: 0;
}
.spin.modal-content {
    background: url('https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/06/SPIN-SPOTIFY-Email-Pop_Up-1591038894.jpg')no-repeat center center/cover;
    width: 100%;
}
.spin-logo {
    width: 180px;
    margin: 0 auto;
}
.modal-header{
 border-bottom:0 !important;
}
div#myModal {
    top: 50px !important;
}


		</style>
	

        	<link href='https://fonts.googleapis.com/css?family=Vollkorn:400italic,700italic,400,700' rel='stylesheet' type='text/css'>
	<script type="text/javascript" src="https://id.radinfluencer.com/uid.php?SITEID=1046&LICENSE=91546F0C41EE3F550C4E3254315671149175931B817D454E3C0A1130F48F6CCB"></script>
        
                  <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
          <script src="//widget.sellwild.com/spin/gatewayclassiccars-spin.js"></script>
                
  

  <script type="text/javascript">ggv2id='fjyqk3kk';</script>
  <script type="text/javascript" src="https://js.gumgum.com/services.js"></script>
       
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  // Used in gallery.js to refresh ad slots on slide change
  var galleryTopSidebar, galleryTopLeaderboard;
  
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21909597396/spin_gallery_sidebar_right_top_300x250', [[336, 280], [300, 250], [300, 600]], 'div-gpt-ad-1594756841681-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_gallery_sidebar_right_bottom_300x250', [[336, 280], [300, 250], [300, 600]], 'div-gpt-ad-1594756789780-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_gallery_sidebar_right_middle_300x250', [[336, 280], [300, 250], [300, 600]], 'div-gpt-ad-1594756888168-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_gallery_top_728x90', [[728, 90], [970, 90]], 'div-gpt-ad-1594756823029-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_gallery_bottom_728x90', [[970, 90], [728, 90]], 'div-gpt-ad-1594756749900-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_gallery_inline_left_300x250', [[336, 280], [300, 250]], 'div-gpt-ad-1594756901203-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_gallery_inline_right_300x250', [[336, 280], [300, 250]], 'div-gpt-ad-1594756923574-0').addService(googletag.pubads());
    
    googletag.defineSlot('/21909597396/spin_bottom_728x90', [[728, 90], [970, 90]], 'div-gpt-ad-1581121668000-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_sidebar_300x250', [[300, 600], [300, 250], [336, 280]], 'div-gpt-ad-1581121725019-0').addService(googletag.pubads());
    
    galleryTopSidebar = googletag.defineSlot('/21909597396/spin_top_300x250', [[336, 280], [300, 250], [300, 600]], 'div-gpt-ad-1581121628326-0').addService(googletag.pubads());
    galleryTopLeaderboard = googletag.defineSlot('/21909597396/spin_top_728x90', [[970, 90], [728, 90]], 'div-gpt-ad-1581121771901-0').addService(googletag.pubads());
    
    googletag.defineSlot('/21909597396/spin_bottom_300x250', [[336, 280], [300, 250], [300, 600]], 'div-gpt-ad-1581121797715-0').addService(googletag.pubads());
    googletag.defineOutOfPageSlot('/21909597396/social_embed_OOP', 'div-gpt-ad-1583262325792-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_content_rec_620x486', [620, 486], 'div-gpt-ad-1583264329801-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_bottom_728x90', [728, 90], 'div-gpt-ad-1587150461408-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_videoadhesion_1x1', [1, 1], 'div-gpt-ad-1588037514110-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_pagegrabberaction_1x1', [1, 1], 'div-gpt-ad-1588037562896-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_pagegrabber_1x1', [1, 1], 'div-gpt-ad-1588037608145-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_brandreveal_1x1', [1, 1], 'div-gpt-ad-1588037638022-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_bottomadhesion_1x1', 'div-gpt-ad-1588037669539-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_apester_1x1', [1, 1], 'div-gpt-ad-1592604005013-0').addService(googletag.pubads());
    
    googletag.defineSlot('/21909597396/spin_HP_top_728x90', [[970, 90], [970, 250], [728, 90]], 'div-gpt-ad-1600530210302-0').addService(googletag.pubads());
    googletag.defineSlot('/21909597396/spin_HP_bottom_728x90', [[970, 90], [970, 250], [728, 90]], 'div-gpt-ad-1600739957915-0').addService(googletag.pubads());    
    googletag.defineSlot('/21909597396/spin_HP_top_300x250', [300, 250], 'div-gpt-ad-1600739993070-0').addService(googletag.pubads());
    
    googletag.pubads().enableSingleRequest();
    googletag.pubads().disableInitialLoad();
    googletag.enableServices();
  });
</script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MKMBD9H');</script>
<!-- End Google Tag Manager -->

<script>
rhombusSiteId = 1116568;
rhombusOOPViewUrl = '%%VIEW_URL_UNESC%%';
if(window.frameElement !== null) {
    window.top['rhombusSiteId'] = rhombusSiteId;
    window.top['rhombusOOPViewUrl'] = rhombusOOPViewUrl;
}

(function() {
           var gads = window.top.document.createElement('script');
           gads.type = 'text/javascript';
           gads.id = 'rhscript';
           gads.src = 'https://cdn.rhombusads.com/js/rh.min.js';
           var node = window.top.document.getElementsByTagName('script')[0];
           node.parentNode.insertBefore(gads, node);
       })();
</script>

<script data-cfasync="false" type="text/javascript">
(function(w, d) {
var s = d.createElement('script');
s.src = '//cdn.adpushup.com/41159/adpushup.js';
s.type = 'text/javascript'; s.async = true;
(d.getElementsByTagName('head')[0] || d.getElementsByTagName('body')[0]).appendChild(s);
})

(window, document);
</script>



<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '1884860681608314');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=1884860681608314&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

	<!-- Quantcast Tag -->
	<script type=“text/javascript”>
	var _qevents = _qevents || [];
	(function() {
	var elem = document.createElement(‘script’);
	elem.src = (document.location.protocol == “https:” ? “https://secure” : “http://edge”) + “.quantserve.com/quant.js”;
	elem.async = true;
	elem.type = “text/javascript”;
	var scpt = document.getElementsByTagName(‘script’)[0];
	scpt.parentNode.insertBefore(elem, scpt);
	})();
	_qevents.push({
	qacct:“p-C_eu3rdPU2k53”
	});
	</script>
	<noscript>
	<div style=“display:none;“>
	<img src=“//pixel.quantserve.com/pixel/p-C_eu3rdPU2k53.gif” border=“0" height=“1” width=“1" alt=“Quantcast”/>
	</div>
	</noscript>
	<!-- End Quantcast tag -->





<style>
#div-gpt-ad-1583264329801-0 {
	height: 586px !important;
}
#div-gpt-ad-1583264329801-0 > div {
	height: 586px !important;
}

#div-gpt-ad-1583264329801-0  iframe	 {
	height: 586px !important;
}

div#div-gpt-ad-1587150461408-0 {
    text-align: center;
    margin: 14px;
}


</style>

    </head>
    <body class="post-template-default single single-post postid-360898 single-format-image">
    
        <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MKMBD9H"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

                        <!-- Google Tag Manager -->
                <noscript>
                    <iframe
                            src="//www.googletagmanager.com/ns.html?id=GTM-N8C7Q9"
                            height="0" width="0" style="display:none;visibility:hidden"></iframe>
                </noscript>
                <script>
                    dataLayer = [{"postId":360898,"pagetype":"article-page","author":"SPIN Staff","category":"new music","publishedDate":"2020102215","parentTag":"none","tags":"The Weeknd"}];
                                        (function() {
                        window.dataLayer = window.dataLayer || [];
                        window.dataLayer.push({
                            'gtm.start': new Date().getTime(), event: 'gtm.js'
                        });
                        window.createScript("//www.googletagmanager.com/gtm.js?id=GTM-N8C7Q9");
                    })();
                </script>
                <!-- End Google Tag Manager -->
                
                    <div id="menu" class="navbar navbar-default navbar-fixed-top " role="navigation">
    <div class="container">
        
        <div class="inner-nav-holder">

            

            <div class="collapse navbar-collapse">
                <ul class="main-nav nav navbar-nav">
                    
                                                                                                    <li class="logo">
                                <div class="navbar-header">
                                    <a href="/" class="navbar-brand" id="logo">
                                                                                    <img src="/wp-content/themes/spin/assets/images/spin-logo.svg" alt="" width="140" height="66">
                                                                            </a>
                                </div>
                            </li>
                                                        <li class="  ">
                                <a href="https://www.spin.com/news/"  >
                                    News
                                                                    </a>

                                
                            </li>

                        
                                                                                                    <li class="  ">
                                <a href="https://www.spin.com/new-music/"  >
                                    New Music
                                                                    </a>

                                
                            </li>

                        
                                                                                                    <li class="  ">
                                <a href="https://www.spin.com/features/"  >
                                    Features
                                                                    </a>

                                
                            </li>

                        
                                                                                                    <li class="  ">
                                <a href="https://www.spin.com/lists/"  >
                                    Lists
                                                                    </a>

                                
                            </li>

                        
                                                                                                    <li class="  ">
                                <a href="https://www.spin.com/archives/"  >
                                    The Archives
                                                                    </a>

                                
                            </li>

                        
                                                                                                    <li class="  dt-item">
                                <a href="https://www.spin.com/death-and-taxes/"  >
                                    death and taxes
                                                                    </a>

                                
                            </li>

                        
                    
                </ul>
                <div class="social-and-search">
                    <div class="search">
                        <form role="search" action="/" method="GET" id="header-search">                            
                            <div class="query-holder">
                                <input type="text" name="s" placeholder="SEARCH" autocomplete="off">
                            </div>
                            <span class="search-submit"></span>
                        </form>
                    </div>
                </div>
            </div>
            
        </div>
    </div>
    <div class="social-block">
                    <ul class="social-links">
                                                                            <li>
                            <a class="icon-facebook" href="https://www.facebook.com/spin" target="_blank"></a>
                        </li>
                                                                                <li>
                            <a class="icon-twitter" href="https://www.twitter.com/spin" target="_blank"></a>
                        </li>
                                                                                <li>
                            <a class="icon-instagram" href="https://www.instagram.com/spinmag" target="_blank"></a>
                        </li>
                                                                                                                                                                                                                                <li>
                            <a class="icon-youtube" href="https://www.youtube.com/user/spin/" target="_blank"></a>
                        </li>
                                                                </ul>
            </div>
</div>                
                
                                                    <div class="social-holder sticky-header">
                    <div class="social-icons">
    <div class="social-container">
        <div class="logo"><a href="/"></a></div>
        <div class="title">Share < br />this article:</div>
                            <div class="email sharrre" data-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-short-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-utm-source="share-email" data-text="The Weeknd Finds a New Body in Bloody &#039;Too Late&#039; Video" data-title="Email" ></div>
                                                <div class="facebook sharrre" data-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-short-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-utm-source="share-fb" data-text="The Weeknd Finds a New Body in Bloody &#039;Too Late&#039; Video" data-title="Share" ></div>
                                                <div class="twitter sharrre" data-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-short-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-utm-source="share-tw" data-text="The Weeknd Finds a New Body in Bloody &#039;Too Late&#039; Video" data-title="Tweet" ></div>
                                                <div class="reddit sharrre" data-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-short-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-utm-source="share-red" data-text="The Weeknd Finds a New Body in Bloody &#039;Too Late&#039; Video" data-title="Reddit" ></div>
                                                </div>
</div>                </div>
                    
        
                    <div class="container ad-container">
                  <div class="ad_desktop leaderboard">
    <!-- /21909597396/spin_top_728x90 -->
    <div id='div-gpt-ad-1581121771901-0'>
      <script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1581121771901-0'); });
      </script>
    </div>
  </div>
            </div>

            <div class="container ad-container">

              <!-- /21909597396/spin_apester_1x1 -->
              <div id='div-gpt-ad-1592604005013-0' style='width: 1px; height: 1px;'>
                <script>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1592604005013-0'); });
                </script>
              </div>
                					        			<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
			<div id="gpt-passback">
			  <script>
			    window.googletag = window.googletag || {cmd: []};
			    googletag.cmd.push(function() {
			    googletag.defineSlot('/21909597396/spin_outstream_1x1', [1, 1], 'gpt-passback').addService(googletag.pubads());
			    googletag.enableServices();
			    googletag.display('gpt-passback');
			    });
			  </script>
			</div>
					                                    </div>
        

            <div class="container main-container">
        <div class="row">
            <div class="sidebar-bg"></div>
            <div class="col-sm-8 left-col">
                            
<div class="article-body" itemScope itemType="https://schema.org/Article">

        <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
    <meta itemprop="name" content="Spin">
    <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
        <link itemprop="url" content="https://www.spin.com/wp-content/themes/spin/assets/images/logo.png">
        <meta itemprop="width" content="470">
        <meta itemprop="height" content="225">
    </div>
</div>
                    <div class="article-title">
        <h2 class="category">
                    <a href="https://www.spin.com/new-music/">
                New Music <span>\</span>
            </a>
            </h2>
    	<h1 itemprop="headline" class="title">
		The Weeknd Finds a New Body in Bloody &#8216;Too Late&#8217; Video
	</h1>
    <h2 class="subtitle"> Things get out of control in a hurry </h2>
</div>        
                    <div class="author">
                                                                                        <span itemprop="author">
                                                    <a href="https://www.spin.com/author/spin-staff/">SPIN Staff</a>
                                            </span>

                                                                
                    <span class="date" itemprop="datePublished" content="2020-10-22T15:05:00+00:00"> | October 22, 2020 - 3:05 pm</span>
                
                                            </div>
        
                                    <div class="social-holder">
                    <div class="social-icons post-header">
    <div class="social-container">
        <div class="logo"><a href="/"></a></div>
        <div class="title">Share < br />this article:</div>
                            <div class="email sharrre" data-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-short-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-utm-source="share-email" data-text="The Weeknd Finds a New Body in Bloody &#039;Too Late&#039; Video" data-title="Email" ></div>
                                                <div class="facebook sharrre" data-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-short-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-utm-source="share-fb" data-text="The Weeknd Finds a New Body in Bloody &#039;Too Late&#039; Video" data-title="Share" ></div>
                                                <div class="twitter sharrre" data-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-short-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-utm-source="share-tw" data-text="The Weeknd Finds a New Body in Bloody &#039;Too Late&#039; Video" data-title="Tweet" ></div>
                                                <div class="reddit sharrre" data-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-short-url="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/" data-utm-source="share-red" data-text="The Weeknd Finds a New Body in Bloody &#039;Too Late&#039; Video" data-title="Reddit" ></div>
                                                </div>
</div>                </div>
            
                            <div class="featured-embed-holder format-image">
                    			<div class="article-image-holder">
			    <div class="mainembed photoembed mainembed-full align-center">
        <div class="img-wrap">
                            <img itemprop="image" src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/10/USUMV2001679-1603394226.jpg" alt="USUMV2001679-1603394226" width="1194" height="693">
                    </div>
                            <div class="credit-wrapper">
                <div class="credit"><small>CREDIT:</small> YouTube</div>
            </div>
            </div>

		</div>
	                </div>
                    
            <div class="article-content-holder">

            <link itemprop="mainEntityOfPage" href="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/">
            <meta itemprop="dateModified" content="2020-10-22T15:17:52+00:00">

            
                            <div itemprop="articleBody" class="single-content-holder">

                                        <div class="article-content clearfix">
                                                                                                                                                        <p>It&#8217;s been a big year for <a href="http://www.spin.com/tag/the-weeknd" target="_blank" rel="noopener">the Weeknd</a>. His latest album, <a href="https://www.spin.com/2020/02/the-weeknd-announces-new-album/" target="_blank" rel="noopener"><em>After Hours</em></a>, hit No. 1 on the <em>Billboard</em> 200. He took home all of the <a href="https://www.spin.com/2020/08/mtv-vmas-here-are-all-of-the-winners-updating/" target="_blank" rel="noopener">big awards</a> at the <a href="https://www.spin.com/2020/08/the-weeknd-shines-in-vmas-kick-off-performance-of-blinding-lights/" target="_blank" rel="noopener">VMAs</a> in August and if that wasn&#8217;t enough action, he starred in and wrote an episode of <a href="https://www.spin.com/2020/04/the-weeknd-is-now-an-american-dad-co-writer/" target="_blank" rel="noopener"><em>American Dad</em>.</a></p>
<p>After sharing videos for &#8220;<a href="https://www.spin.com/2020/03/the-weeknd-goes-gory-and-headless-for-in-your-eyes-video/" target="_blank" rel="noopener">In Your Eyes</a>&#8221; and &#8220;<a href="https://www.spin.com/2020/07/the-weeknd-snowchild-video/" target="_blank" rel="noopener">Snowchild</a>,&#8221; the artist has dropped another one titled &#8220;Too Late.&#8221; The video starts off with a pair of sisters who had plastic surgery and on the drive home, find the Weeknd&#8217;s head in the middle of the street. They start doing weird things with it before the clip takes a violent turn.</p>    <script>
    (function (d, s, n) {
        var js, fjs = d.getElementsByTagName(s)[0];
        js = d.createElement(s);
        js.className = n;
        js.src = "//stream.playbuzz.com/player/19fbf396-18e3-4434-8015-714fb7986012";
        fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'playbuzz-stream'));
    </script>
    <div id="19fbf396-18e3-4434-8015-714fb7986012" style="margin-bottom: 20px"></div>
  
<p>Check it out below.</p>
<div class="mainembed videoembed mainembed-full_width align-center no-image">
            <div class="video-embed-code horizontal">
            <iframe width="" height="" src="https://www.youtube.com/embed/Wh8DT09QCHI" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
        </div>
    </div>
<p>Last week, the Weeknd shared a remix of &#8220;In Your Eyes&#8221; where he teamed with none other than Kenny G. for the jazzy version. He&#8217;s also unleashed a remix of &#8220;<a href="https://www.spin.com/2020/08/the-weeknd-unearths-remix-of-lana-del-reys-money-power-glory/" target="_blank" rel="noopener">Money Power Glory</a>&#8221; featuring Lana Del Rey.</p>
<p>Additionally, the artist also known as Abel Tesfaye <a href="https://www.spin.com/2020/06/the-weeknd-donates-1-million-to-covid-relief-efforts/" target="_blank" rel="noopener">donated</a> $1 million to COVID relief funds and has been an outspoken supporter of Black Lives Matter.</p>
    <div class="author-footer">
        <div class="inner">
            <div class="avatar">
                <a href="https://www.spin.com/author/spin-staff/"><img   src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-60x60.jpg" class="attachment-article/nav-thumb size-article/nav-thumb" alt="" srcset="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-60x60.jpg 60w, https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-150x150.jpg 150w, https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-300x300.jpg 300w, https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-320x320.jpg 320w, https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-145x145.jpg 145w, https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-117x117.jpg 117w, https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-360x360.jpg 360w, https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon-426x426.jpg 426w, https://s3-us-west-1.amazonaws.com/static-spin-com/files/2015/04/SPIN-icon.jpg 500w" sizes="(max-width: 60px) 100vw, 60px" /></a>
            </div>
            <div class="text">
                <div class="name">
                    <a href="https://www.spin.com/author/spin-staff/">SPIN Staff</a>
                </div>
                <div class="list">
                    <ul>
                                                                    </ul>
                </div>
            </div>
        </div>
    </div>
</p>
                                                    
                        
                                            </div>
                </div>
            
                            
                                    
                    
                    <div class="row tags-and-comments">
                <div class="col-sm-9">
                    <div itemprop="keywords" class="tags">
                                                    <strong>Tags:</strong>
                                                            <a href="https://www.spin.com/tag/the-weeknd/">The Weeknd</a>                                                                        </div>
                </div>

                                                            <div class="col-sm-3">
                            <div itemprop="comment" class="comments right">
                                <a href="https://www.spin.com/2020/10/the-weeknd-shares-bloody-too-late-video/#respond" data-disqus-identifier="invalid-id-to-prevent-link-overwrite"><span class="count disqus-comment-count" data-disqus-identifier="360898 https://www.spin.com/?p=360898"></span><span class="article-comment-bubble"></span></a>
                            </div>
                         </div>
                                                </div>
        
        
            </div>
    </div>

            <hr>
    
    
    
    
        <div class="link-exchanges">
        <div class="recommended-module ">
                <div class="title-holder">
        <h2>Recommended for you <span class="red">\</span></h2>
    </div>
            <div class="row">
                                                                                </div>
                        <div class="row">
                                        <div class="col-sm-4">
                        <div class="image-holder">
                            <a href="https://www.spin.com/2020/10/the-weeknd-teams-with-kenny-g-for-jazzy-in-your-eyes-remix/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
                                <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/10/Weeknd_KennyG-1602858244-191x127.jpg" width="191" height="127" alt="The Weeknd Teams With Kenny G for Jazzy &#8216;In Your Eyes&#8217; Remix">
                            </a>
                        </div>
                        <div class="preview-holder">
                            <a href="https://www.spin.com/2020/10/the-weeknd-teams-with-kenny-g-for-jazzy-in-your-eyes-remix/" class="ga-product-impression"
                                data-list-name="Recommended - Article"
                                data-list-position="1">
                                <h3>
                                    The Weeknd Teams With Kenny G for Jazzy &#8216;In Your Eyes&#8217; Remix
                                </h3>
                            </a>
                        </div>
                    </div>
                                                                            <div class="col-sm-4">
                        <div class="image-holder">
                            <a href="https://www.spin.com/2020/10/saturday-night-live-20-of-biggest-breakthrough-musical-performances-since-2000/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
                                <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/10/BeFunky-Collage-1601753378-191x127.jpg" width="191" height="127" alt="<i>Saturday Night Live</i>: 20 of Biggest Breakthrough Musical Performances Since 2000">
                            </a>
                        </div>
                        <div class="preview-holder">
                            <a href="https://www.spin.com/2020/10/saturday-night-live-20-of-biggest-breakthrough-musical-performances-since-2000/" class="ga-product-impression"
                                data-list-name="Recommended - Article"
                                data-list-position="2">
                                <h3>
                                    <i>Saturday Night Live</i>: 20 of Biggest Breakthrough Musical Performances Since 2000
                                </h3>
                            </a>
                        </div>
                    </div>
                                                                            <div class="col-sm-4">
                        <div class="image-holder">
                            <a href="https://www.spin.com/2020/08/the-weeknd-shines-in-vmas-kick-off-performance-of-blinding-lights/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
                                <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/08/GettyImages-1269761226-1598832569-191x127.jpg" width="191" height="127" alt="MTV VMAs 2020: Watch The Weeknd Perform &#8216;Blinding Lights&#8217;">
                            </a>
                        </div>
                        <div class="preview-holder">
                            <a href="https://www.spin.com/2020/08/the-weeknd-shines-in-vmas-kick-off-performance-of-blinding-lights/" class="ga-product-impression"
                                data-list-name="Recommended - Article"
                                data-list-position="3">
                                <h3>
                                    MTV VMAs 2020: Watch The Weeknd Perform &#8216;Blinding Lights&#8217;
                                </h3>
                            </a>
                        </div>
                    </div>
                                                                                </div>
                        <div class="row">
                                        <div class="col-sm-4">
                        <div class="image-holder">
                            <a href="https://www.spin.com/2020/08/the-weeknd-responds-previous-misogynistic-lyrics-esquire-interview/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
                                <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/02/Weeknd-JoshuaBlanchard-1581628388-191x127.jpg" width="191" height="127" alt="The Weeknd Responds to Previous Misogynistic Lyrics">
                            </a>
                        </div>
                        <div class="preview-holder">
                            <a href="https://www.spin.com/2020/08/the-weeknd-responds-previous-misogynistic-lyrics-esquire-interview/" class="ga-product-impression"
                                data-list-name="Recommended - Article"
                                data-list-position="4">
                                <h3>
                                    The Weeknd Responds to Previous Misogynistic Lyrics
                                </h3>
                            </a>
                        </div>
                    </div>
                                                                            <div class="col-sm-4">
                        <div class="image-holder">
                            <a href="https://www.spin.com/2020/08/the-weeknd-unearths-remix-of-lana-del-reys-money-power-glory/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
                                <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/08/lana-del-rey-the-weeknd-1597527664-191x127.jpg" width="191" height="127" alt="The Weeknd Unearths Remix of Lana Del Rey’s &#8216;Money Power Glory&#8217;">
                            </a>
                        </div>
                        <div class="preview-holder">
                            <a href="https://www.spin.com/2020/08/the-weeknd-unearths-remix-of-lana-del-reys-money-power-glory/" class="ga-product-impression"
                                data-list-name="Recommended - Article"
                                data-list-position="5">
                                <h3>
                                    The Weeknd Unearths Remix of Lana Del Rey’s &#8216;Money Power Glory&#8217;
                                </h3>
                            </a>
                        </div>
                    </div>
                                                                            <div class="col-sm-4">
                        <div class="image-holder">
                            <a href="https://www.spin.com/2020/08/the-weeknd-shares-posthumous-juice-wrld-collab/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
                                <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2016/12/theweeknd-1482860493-191x127.jpg" width="191" height="127" alt="The Weeknd Shares Posthumous Juice WRLD Collab">
                            </a>
                        </div>
                        <div class="preview-holder">
                            <a href="https://www.spin.com/2020/08/the-weeknd-shares-posthumous-juice-wrld-collab/" class="ga-product-impression"
                                data-list-name="Recommended - Article"
                                data-list-position="6">
                                <h3>
                                    The Weeknd Shares Posthumous Juice WRLD Collab
                                </h3>
                            </a>
                        </div>
                    </div>
                            </div>
        </div>
        <sellwild></sellwild>
    </div>



<div class="OUTBRAIN" data-src="DROP_PERMALINK_HERE" data-widget-id="AR_1"></div> <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>




    
                </div>
            <div class="col-sm-4 sidebar">
                                    <div class="sidebar-module ">
	
<div class="feed feed-tile"><div class="title-holder clearfix"><div class="title left"><a href="https://www.spin.com/reviews/"><h2>
                                                Reviews
                    
    <span class="red">\</span></h2></a></div><div class="see-all right"><a href="https://www.spin.com/reviews/">Read More &raquo;</a></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="https://www.spin.com/2020/10/bruce-springsteens-letter-to-you-is-a-prayer-of-strength-and-resilience-in-the-face-of-death/"     class=" ga-product-impression"
    data-list-name="Reviews - article-page"
    data-list-position="1"
><img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/10/2700-1603221478-145x145.jpg" alt="Bruce Springsteen’s <i>Letter to You</i> Is a Prayer of Strength and Resilience in the Face of Death"></a></div><div class="preview-holder"><a href="https://www.spin.com/2020/10/bruce-springsteens-letter-to-you-is-a-prayer-of-strength-and-resilience-in-the-face-of-death/"     class="title-link  ga-product-impression"
    data-list-name="Reviews - article-page"
    data-list-position="1"
>Bruce Springsteen’s <i>Letter to You</i> Is a Prayer of Strength and Resilience in the Face of Death</a></div><div class="overlay"></div></div><div class="post"><div class="image-holder"><a href="https://www.spin.com/2020/10/tom-petty-wildflowers-reissue-album-review/"     class=" ga-product-impression"
    data-list-name="Reviews - article-page"
    data-list-position="2"
><img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/10/tom_petty_cover-1602777207-145x145.jpg" alt="Tom Petty’s <i>Wildflowers &#038; All the Rest</i> Offers an In-Depth Look Into One of His Finest Moments"></a></div><div class="preview-holder"><a href="https://www.spin.com/2020/10/tom-petty-wildflowers-reissue-album-review/"     class="title-link  ga-product-impression"
    data-list-name="Reviews - article-page"
    data-list-position="2"
>Tom Petty’s <i>Wildflowers &#038; All the Rest</i> Offers an In-Depth Look Into One of His Finest Moments</a></div><div class="overlay"></div></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="https://www.spin.com/2020/08/the-killers-double-down-on-arena-rock-with-imploding-the-mirage/"     class=" ga-product-impression"
    data-list-name="Reviews - article-page"
    data-list-position="3"
><img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/08/the-killers-imploding-the-mirage-1597934317-145x145.jpg" alt="The Killers Double Down on Arena Rock With <i>Imploding The Mirage </i>"></a></div><div class="preview-holder"><a href="https://www.spin.com/2020/08/the-killers-double-down-on-arena-rock-with-imploding-the-mirage/"     class="title-link  ga-product-impression"
    data-list-name="Reviews - article-page"
    data-list-position="3"
>The Killers Double Down on Arena Rock With <i>Imploding The Mirage </i></a></div><div class="overlay"></div></div><div class="post"><div class="image-holder"><a href="https://www.spin.com/2020/07/folklore-is-taylor-swifts-smoldering-pop-rebellion-finally/"     class=" ga-product-impression"
    data-list-name="Reviews - article-page"
    data-list-position="4"
><img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/07/EdnBtIoWkAITJzC-1595507786-145x145.jpg" alt="<i>folklore</i> Is Taylor Swift’s Smoldering Pop Rebellion — Finally"></a></div><div class="preview-holder"><a href="https://www.spin.com/2020/07/folklore-is-taylor-swifts-smoldering-pop-rebellion-finally/"     class="title-link  ga-product-impression"
    data-list-name="Reviews - article-page"
    data-list-position="4"
><i>folklore</i> Is Taylor Swift’s Smoldering Pop Rebellion — Finally</a></div><div class="overlay"></div></div></div></div></div><div id="custom_html-3" class="widget_text widget_custom_html"><div class="textwidget custom-html-widget"><!-- /21909597396/spin_sidebar_300x250 -->
<div id='div-gpt-ad-1581121725019-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1581121725019-0'); });
  </script> 
</div>

<!-- /21909597396/spin_bottom_300x250 -->
<div id='div-gpt-ad-1581121797715-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1581121797715-0'); });
  </script>
</div>
</div></div><div id="custom_html-2" class="widget_text widget_custom_html"><div class="textwidget custom-html-widget"><!-- /21909597396/spin_top_300x250 -->
<div id='div-gpt-ad-1581121628326-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1581121628326-0'); });
  </script>
</div>

<!-- apester -->
		<interaction data-token="5e6273f82684540da69093fc" data-context="true" data-tags="" data-fallback="true"></interaction>
</div></div><div id="custom_html-6" class="widget_text widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
            window.googletag = window.googletag || {cmd: []};
            googletag.cmd.push(function() {
            googletag.defineSlot('/21909597396/spin_apester_1x1', [1, 1], 'div-gpt-ad-1592604005013-0').addService(googletag.pubads());
            googletag.pubads().enableSingleRequest();
            googletag.pubads().disableInitialLoad();
            googletag.enableServices();
          });
 </script>
	<!-- /21909597396/spin_apester_1x1 -->
	<div id='div-gpt-ad-1592604005013-0' style='width: 1px; height: 1px;'>
	                <script>
	                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1592604005013-0'); });
	                </script>
	</div></div></div>
                            </div>
        </div>
    </div>
 		
      
 
        
          <script type="text/javascript" src="https://static.apester.com/js/sdk/latest/apester-sdk.js" async></script>
        
    <div class="container footer-ad-holder">
          <div class="ad_desktop leaderboard">
    <!-- /21909597396/spin_top_728x90 -->
    <div id='div-gpt-ad-1581121771901-0'>
      <script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1581121771901-0'); });
      </script>
    </div>
  </div>
    </div>

        <div id='div-gpt-ad-1587150461408-0'>
          <script>
            googletag.cmd.push(function() { googletag.display('div-gpt-ad-1587150461408-0'); });
            </script>
        </div>
	
	 <!-- /21909597396/spin_videoadhesion_1x1 -->
	<div id='div-gpt-ad-1588037514110-0' style='width: 1px; height: 1px;'>
  	<script>
    	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1588037514110-0'); });
  	</script>
	</div>

	<!-- /21909597396/spin_pagegrabberaction_1x1 -->
	<div id='div-gpt-ad-1588037562896-0' style='width: 1px; height: 1px;'>
  	<script>
    	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1588037562896-0'); });
  	</script>
	</div>

	<!-- /21909597396/spin_pagegrabber_1x1 -->
	<div id='div-gpt-ad-1588037608145-0' style='width: 1px; height: 1px;'>
  	<script>
    	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1588037608145-0'); });
  	</script>
	</div>

	<!-- /21909597396/spin_bottomadhesion_1x1 -->
	<div id='div-gpt-ad-1588037669539-0' style='width: 1px; height: 1px;'>
  	<script>
    	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1588037669539-0'); });
  	</script>
	</div>	
	
	<!-- /21909597396/spin_brandreveal_1x1 -->
	<div id='div-gpt-ad-1588037638022-0' style='width: 1px; height: 1px;'>
  	<script>
    	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1588037638022-0'); });
  	</script>
	</div>

                      <div style="width: 728px; height: 90px; margin: auto">
          <!-- /21909597396/spin_bottom_728x90 -->
      <div id='div-gpt-ad-1584490356178-0'>
        <script>
          googletag.cmd.push(function() { googletag.display('div-gpt-ad-1584490356178-0'); });
        </script>
      </div>
        
  </div>


<script defer src="https://ads.pro-market.net/ads/scripts/site-159245.js"></script>
            <div class="container">
        <sellwild></sellwild>
      </div>
          
    <div class="footer-recommended">
      <div class="container">
        <h3>Editor's Picks</h3>
        <div class="row">
                      <a href="/2020/03/torres-describes-harrowing-48-hours-trying-to-return-home-during-coronavirus-pandemic/">
                            <div class="post col-sm-4">
                <div class="overlay"></div>
                <div class="img-wrap">
                  <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/03/TORRES_0238_FL_byMichaelLavine-1584730142-313x209.jpg" width="313" height="209" alt="Torres Describes Harrowing 48 Hours Trying to Return Home ">
                </div>
                <div class="title">
                  <div>Torres Describes Harrowing 48 Hours Trying to Return Home </div>
                </div>
              </div>
            </a>
                      <a href="/2020/03/the-viral-countdown-inside-the-concert-industrys-race-to-react-to-the-covid-19-pandemic/">
                            <div class="post col-sm-4">
                <div class="overlay"></div>
                <div class="img-wrap">
                  <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/03/GettyImages-1206292268_opt-1584024606-313x209.jpg" width="313" height="209" alt="The Viral Countdown: The Race to React to COVID-19">
                </div>
                <div class="title">
                  <div>The Viral Countdown: The Race to React to COVID-19</div>
                </div>
              </div>
            </a>
                      <a href="/2020/03/the-cost-of-coronavirus-how-young-guv-ended-up-homeless-after-tour-cancellation/">
                            <div class="post col-sm-4">
                <div class="overlay"></div>
                <div class="img-wrap">
                  <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/03/Young_Guv_Danielle_Parsons-1-1584893192-313x209.jpg" width="313" height="209" alt="The Cost of Coronavirus: How Young Guv Ended Up Stranded">
                </div>
                <div class="title">
                  <div>The Cost of Coronavirus: How Young Guv Ended Up Stranded</div>
                </div>
              </div>
            </a>
                  </div>
      </div>
    </div>
  
<footer id="footer">
    <div class="container">
        <div class="comscore">
            <div class="comscore-header clearfix">
                <div class="right">
                    <div class="mobile-site-footer">
                                        </div>
                    <div class="footer-logo">
                        <a href="/">
                                <img src="/wp-content/themes/spin/assets/images/Spinlogo-footer.svg" alt="" width="92" height="43">
                        </a>
                    </div>
                    <div class="email-footer-box">
                        <span class="left-spin-img">
                         <img src="https://s3-us-west-1.amazonaws.com/static-spin-com/files/2020/05/footer-spin-logo-1589231776.png">
                        </span>
                        <span class="email-ft-input">
                        
	<section id="yikes-mailchimp-container-1" class="yikes-mailchimp-container yikes-mailchimp-container-1 ">
				<form id="newsletter-1" class="yikes-easy-mc-form yikes-easy-mc-form-1  " method="POST" data-attr-form-id="1">

													<label for="yikes-easy-mc-form-1-EMAIL"  class="EMAIL-label yikes-mailchimp-field-required ">

										<!-- dictate label visibility -->
																					<span class="EMAIL-label">
												Email Address											</span>
										
										<!-- Description Above -->
										
										<input id="yikes-easy-mc-form-1-EMAIL"  name="EMAIL"  placeholder="Enter Email Address"  class="yikes-easy-mc-email "  required="required" type="email"  value="">

										<!-- Description Below -->
										
									</label>
									
				<!-- Honeypot Trap -->
				<input type="hidden" name="yikes-mailchimp-honeypot" id="yikes-mailchimp-honeypot-1" value="">

				<!-- List ID -->
				<input type="hidden" name="yikes-mailchimp-associated-list-id" id="yikes-mailchimp-associated-list-id-1" value="16b8d523ac">

				<!-- The form that is being submitted! Used to display error/success messages above the correct form -->
				<input type="hidden" name="yikes-mailchimp-submitted-form" id="yikes-mailchimp-submitted-form-1" value="1">

				<!-- Submit Button -->
				<button type="submit" class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-1 btn btn-primary "> <span class="yikes-mailchimp-submit-button-span-text">Submit</span></button>				<!-- Nonce Security Check -->
				<input type="hidden" id="yikes_easy_mc_new_subscriber_1" name="yikes_easy_mc_new_subscriber" value="9f17ef485d">
				<input type="hidden" name="_wp_http_referer" value="/2020/10/the-weeknd-shares-bloody-too-late-video/" />				
			</form>
			<!-- Mailchimp Form generated by Easy Forms for Mailchimp v6.6.4 (https://wordpress.org/plugins/yikes-inc-easy-mailchimp-extender/) -->

			</section>
	
                        </span>
                    </div>
                </div>
                <div class="left">
                                                                <ul class="social-links">
                                                                                                <li>
                                        <a href="https://www.facebook.com/spin" target="_blank">
                                            <div class="social-icon square facebook">
                                                <span class="icon-facebook"></span>
                                            </div>
                                        </a>
                                    </li>
                                                                                                                                <li>
                                        <a href="https://www.twitter.com/spin" target="_blank">
                                            <div class="social-icon square twitter">
                                                <span class="icon-twitter"></span>
                                            </div>
                                        </a>
                                    </li>
                                                                                                                                <li>
                                        <a href="https://www.instagram.com/spinmag" target="_blank">
                                            <div class="social-icon square instagram">
                                                <span class="icon-instagram"></span>
                                            </div>
                                        </a>
                                    </li>
                                                                                                                                                                                                                                                                                                                                                                                <li>
                                        <a href="https://www.youtube.com/user/spin/" target="_blank">
                                            <div class="social-icon square youtube">
                                                <span class="icon-youtube"></span>
                                            </div>
                                        </a>
                                    </li>
                                                                                    </ul>
                                            <div class="menu">
                                <a href="https://www.spin.com/news" alt="news">NEWS</a>
    <a href="https://www.spin.com/new-music" alt="new music">NEW MUSIC</a>
    <a href="https://www.spin.com/culture" alt="culture">CULTURE</a>
    <a href="https://www.spin.com/features" alt="features">FEATURES</a>
    <a href="https://www.spin.com/lists" alt="lists">LISTS</a>
    <a href="https://www.spin.com/archives" alt="the archives">THE ARCHIVES</a>
    <a href="/cdn-cgi/l/email-protection#fc88958c8fbc8f8c9592d29f9391" alt="contact us">CONTACT US</a>
                        </div>
                             A <a href="https://nextmanagementpartners.com/">Next Management Partners</a> brand.<br>
                             To contact us about advertising please email <strong>contact (at) spin.com</strong>

                    
                    <div class="comscore-header-links">
                                                    <a class="comscore--link comscore--header-link" href="/privacy-policy" target="_blank">Privacy Policy</a>
                            <a class="comscore--link comscore--header-link" href="/about-our-ads" target="_blank" class="cs_aboutBug">About Our Ads</a>
                            <a class="comscore--link" href="/terms" target="_blank">Terms Of Use</a>
                                            </div>
                </div>
            </div>
                   </div>
    </div>
</footer>        
            <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
        window.createScript(document.location.protocol + '//platform.twitter.com/widgets.js');
    </script>
     

        <script id="ad_slot" type="text/template">
            <div class="ad_desktop" data-sizes="[[160,600],[300,250],[300,600]]" data-position="300c"></div>
        </script>
        
        <div id="hidden_div" class="hidden"></div>

        <div id="ad_native_instream" class="ad_desktop" data-sizes="[2,2]" data-position="native_instream_lazy"></div>
<div id="ad_native_rightrail" class="ad_desktop" data-sizes="[2,2]" data-position="native_detail_lazy"></div><script type="text/html" id="sc_interrupter_template">
<div class="post row wp-pi-sponsored-content-interrupter">
    <div class="posts-holder"> 
                    <div class="interrupter-post"> 
            <div class="image-holder"> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <img src="<% if(typeof post_images == "object") { print(post_images.feed.split) } %>"> 
            </a> 
            <div class="text-overlay">
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>>
                    <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                </a>
            </div> 
        </div> 
        <div class="preview-holder"> 
                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                <div class="shared-by">
                    <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                </div>
            <% } %>    
                <h2> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <% if(typeof post_title !== "undefined") { print(post_title) } %>
            </a> 
        </h2> 
        <% if(typeof sponsor_image !== "undefined") { %>
            <div class="sponsor"> 
                                <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %>

                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                    <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                </a> 
                
                                <% if((typeof show_sponsor === "undefined" || show_sponsor )
                        && typeof sponsor_name !== "undefined") { %>
                    <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %>
                    <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                        <span>
                            <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                        </span>
                    </a> 
                <% } %>
            </div> 
        <% } %>
                <div class="preview"> 
            <% if(typeof post_preview !== "undefined") { print(post_preview) } %>
        </div> 
            </div> 
</div>            </div> 
</div>
</script><script type="text/html" id="sc_interrupter_template_sidebar">
<div class="sidebar-module wp-pi-sponsored-content-interrupter"> 
    <div class="title-holder clearfix"> 
            <div class="title left"> 
        <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>">
            <h3>
                <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                <span class="red">\</span>
            </h3>
        </a>
    </div> 
    </div> 
    <div class="posts-holder"> 
        <div class="interrupter-post"> 
            <div class="image-holder"> 
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>> 
                    <img src="<% if(typeof post_images == "object") { print(post_images.sidebar) } %>">
                </a> 
            </div> 
            <div class="preview-holder"> 
                                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                        <div class="shared-by">
                            <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                        </div>
                    <% } %>    
                                <h2> 
                    <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>>
                        <% if(typeof post_title !== "undefined") { print(post_title) } %>
                    </a> 
                </h2> 
                <% if(typeof sponsor_image !== "undefined") { %>
                     
                        <div class="sponsor">
                                                        <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                            
                            <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                            </a> 
                            <% if((typeof show_sponsor === "undefined" || show_sponsor)
                                    && typeof sponsor_name !== "undefined") { %>
                                <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                    <span>
                                        <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                                    </span>
                                </a> 
                            <% } %>
                        </div> 
                     
                <% } %>
            </div> 
        </div> 
    </div> 
</div>
</script>    <script type="text/html" id="pe_zoom_overlay">
        <div class="pe-zoom-overlay scroll-<%= scroll_dir %>">
            <div class="image-holder">
                <img itemprop="image"
                     src="<%= img_src %>">
            </div>
            <div class="pe-zoom-close-x"></div>
        </div>
    </script><link rel='stylesheet' id='yikes-inc-easy-mailchimp-public-styles-css'  href='https://www.spin.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/css/yikes-inc-easy-mailchimp-extender-public.min.css?ver=0.0.5' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var mobileDetect = {"isMobile":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-mobile-theme/js/mobile_detect.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/img-touch-canvas.js?ver=0.0.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.spin.com/wp-includes/js/wp-util.min.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/mobile-zoom.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-sponsored-content/js/interrupter/interrupter.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/js/bootstrap.min.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/lodash.2.4.1.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/themes/wp-theme-base/assets/js/all.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/themes/spin/assets/js/all.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/modules.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-includes/js/wp-embed.min.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-sharrre/js/jquery.sharrre.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/wp-pi-sharrre/js/sharrre-init.js?ver=0.0.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var yikes_mailchimp_ajax = {"ajax_url":"https:\/\/www.spin.com\/wp-admin\/admin-ajax.php","page_data":"360898","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/www.spin.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/www.spin.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"c4081a9d96","feedback_message_placement":"before"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js?ver=0.0.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var form_submission_helpers = {"ajax_url":"https:\/\/www.spin.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/www.spin.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"360898"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.spin.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js?ver=0.0.5'></script>

        
        

        <!-- /21909597396/social_embed_OOP -->
		<div id='div-gpt-ad-1583262325792-0'>
		<script>
	   	 googletag.cmd.push(function() { googletag.display('div-gpt-ad-1583262325792-0'); });
	  </script>
        
	  
	</div>
	
        
 

    </body>
</html>
