<!doctype html>
<html>
<head>
<meta charset="UTF-8"/>
<title>Remembering So Much for the Afterglow with Everclear&#8217;s Art Alexakis | SPIN</title>
<link rel="icon" href="http://assets.spin.com/favicon.ico"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<meta name="viewport" content="width=device-width">
<link rel="alternate" type="application/rss+xml" title="RSS" href="http://www.spin.com/feed">
<link rel="stylesheet" href="http://www.spin.com/wp-content/themes/spin/assets/css/style.css?aabdc66e75a2a9bfbb17974175348d869ff55161" type="text/css" media="screen"/>
 
<script type="text/javascript">
        clarityPageData = {"site_code":"spin","zone":"article_page"};
    </script>
<script type="text/javascript">
    (function(){
        window.CLARITY = window.CLARITY || [];
        var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
        ns.async = true; ns.type = 'text/javascript'; ns.src = '//lib.pgmcdn.com/clarity-1489097134569.min.js'; s.parentNode.insertBefore(ns, s);
    })();
</script>
<script>var OX_dfp_ads=[['/6419/spin/article_page/leaderboard_top',['728x91','970x251','970x91','728x90','970x250','970x90'],'leaderboard_top_1',{"pos":["leaderboard_top"],"pagetype":["article_page"]}],['/6419/spin/article_page/leaderboard_bottom_lazy',['728x90','970x250','970x90'],'leaderboard_bottom_lazy_1',{"pos":["leaderboard_bottom_lazy"],"pagetype":["article_page"]}],['/6419/spin/article_page/medrec_top',['300x251','300x601','300x250','300x600'],'medrec_top_1',{"pos":["medrec_top"],"pagetype":["article_page"]}],['/6419/spin/article_page/medrec_bottom_lazy',['300x250','300x600'],'medrec_bottom_lazy_1',{"pos":["medrec_bottom_lazy"],"pagetype":["article_page"]}],['/6419/spin/article_page/leaderboard_bottom_first',['728x90','970x250','970x90'],'leaderboard_bottom_first_1',{"pos":["leaderboard_bottom_first"],"pagetype":["article_page"]}],['/6419/spin/article_page/medrec_bottom_first',['300x250','300x600'],'medrec_bottom_first_1',{"pos":["medrec_bottom_first"],"pagetype":["article_page"]}],];</script><script>window.oxDone=function(){CLARITY.push({use:['header','logger'],run:function(header,logger){try{logger.log("Setting OX targeting from template Clarity push","header");header.partners.ox.setTargeting();}catch(e){logger.log("header.oxSetTargeting failed with error : "+e,"error");}}});};(function(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src=(document.location.protocol==='https:'?'https:':'http:')+'//spinmedia-d.openx.net/w/1.0/jstag?nc=6419-SPIN';var node=document.getElementsByTagName('script')[0];node.parentNode.appendChild(s);})();CLARITY.push({use:['header'],run:function(header){header.skipJsInject('openx');}});</script>
<script>var rubicon_ads=[['/6419/spin/article_page/leaderboard_top',[[728,91],[970,251],[970,91],[728,90],[970,250],[970,90]],'leaderboard_top_1'],['/6419/spin/article_page/leaderboard_bottom_lazy',[[728,90],[970,250],[970,90]],'leaderboard_bottom_lazy_1'],['/6419/spin/article_page/medrec_top',[[300,251],[300,601],[300,250],[300,600]],'medrec_top_1'],['/6419/spin/article_page/medrec_bottom_lazy',[[300,250],[300,600]],'medrec_bottom_lazy_1'],];var rubicontag=rubicontag||{};rubicontag.cmd=rubicontag.cmd||[];(function(){var account_id=11872;var rct=document.createElement('script');rct.type='text/javascript';rct.async=true;rct.src=(document.location.protocol==='https:'?'https:':'http:')+'//ads.rubiconproject.com/header/'+account_id+'.js';var node=document.getElementsByTagName('script')[0];node.parentNode.appendChild(rct);})();CLARITY.push({use:['header'],run:function(header){header.skipJsInject('rubicon');}});</script>
<script>CLARITY.push({use:['header'],run:function(header){header.run({"a9":{"account_id":3125},"openx":{"network_code":"6419-SPIN","positions":{"leaderboard_top":"['728x91','970x251','970x91','728x90','970x250','970x90']","leaderboard_bottom_lazy":"['728x90','970x250','970x90']","medrec_top":"['300x251','300x601','300x250','300x600']","medrec_bottom_lazy":"['300x250','300x600']","leaderboard_bottom_first":"['728x90','970x250','970x90']","medrec_bottom_first":"['300x250','300x600']"}},"rubicon":{"account_id":11872,"positions":{"leaderboard_top":"[[728,91],[970,251],[970,91],[728,90],[970,250],[970,90]]","leaderboard_bottom_lazy":"[[728,90],[970,250],[970,90]]","medrec_top":"[[300,251],[300,601],[300,250],[300,600]]","medrec_bottom_lazy":"[[300,250],[300,600]]"}},"yieldbot":{"desktop":"ks66","mobile":"9qk4"}});}});</script> <script>
    if("I11C" in window && I11C.Morph == 1){
        window.CLARITY.push({
            use: ["instart"], 
            run: function(instart) { 
                instart.run({
                    'unblocked_ads': ["leaderboard_top","medrec_top","medrec_bottom_lazy"]
                });
            }
        });
        window.CLARITY.push({use: ["ads"],run: function(Ads) { Ads.zone = 'unblocked'; }});
    }
</script>
 
<meta name="description" content="Everclear’s So Much for the Afterglow, which turns 20 this year, was one of the first CDs--and rock albums in any format--I ever bought. When I recently got on"/>
<meta name="keywords" content="art alexakis,everclear"/>
<link rel="canonical" href="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/"/>
<meta property="og:title" content="Remembering So Much for the Afterglow with Everclear&#8217;s Art Alexakis"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/"/>
<meta property="og:image" content="http://static.spin.com/files/2017/04/Everclear_Trio_Paul-Brown-1493151865.jpg"/>
<meta property="og:image:width" content="6144"/>
<meta property="og:image:height" content="4081"/>
<meta property="og:site_name" content="Spin"/>
<meta property="og:description" content="Everclear’s So Much for the Afterglow, which turns 20 this year, was one of the first CDs&#8211;and rock albums in any format&#8211;I ever bought. When I recently got on the phone with Art Alexakis, head singer-songwriter and the only consistent member of Everclear over their 26-year-and-counting run, I couldn&#039;t resist telling him as much, appreciatively.  He chuckled. “Ah, you’re right in that demographic, eh?”  I am definitely in that demographic. A few degrees more seamy in its subject matter than Smash Mouth&#039;s Fush Yu Mang or Third Eye Blind’s debut&#8211;which I owned on cassettes which my aunt had primitively dubbed the swears out of&#8211;So Much for the Afterglow was one of the most alluring records I heard on rotation on cool older kids’ Discmans in 1998. The Smashing Pumpkins’ Adore seemed similarly dangerous, but Afterglow was certainly the more immediately palpable work. Even now it stands as superior: as an undeniably consistent, well-honed pop-rock compendium which saved Everclear from"/>
<meta property="article:published_time" content="2017-04-27T13:29:53Z"/>
<meta property="article:modified_time" content="2017-04-27T13:57:43Z"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:title" content="Remembering So Much for the Afterglow with Everclear&#8217;s Art Alexakis"/>
<meta name="twitter:description" content="Everclear’s So Much for the Afterglow, which turns 20 this year, was one of the first CDs&#8211;and rock albums in any format&#8211;I ever bought. When I recently got on the phone with Art Alexakis, head singer-songwriter and the only consistent member of Everclear over their 26-year-and-counting run, I couldn&#039;t resist telling him as much, appreciatively.  He chuckled. “Ah, you’re right in that demographic, eh?”  I am definitely in that demographic. A few degrees more seamy in its subject matter than Smash Mouth&#039;s Fush Yu Mang or Third Eye Blind’s debut&#8211;which I owned on cassettes which my aunt had primitively dubbed the swears out of&#8211;So Much for the Afterglow was one of the most alluring records I heard on rotation on cool older kids’ Discmans in 1998. The Smashing Pumpkins’ Adore seemed similarly dangerous, but Afterglow was certainly the more immediately palpable work. Even now it stands as superior: as an undeniably consistent, well-honed pop-rock compendium which saved Everclear from"/>
<meta name="twitter:image" content="http://static.spin.com/files/2017/04/Everclear_Trio_Paul-Brown-1493151865-1024x680.jpg"/>
<meta itemprop="image" content="http://static.spin.com/files/2017/04/Everclear_Trio_Paul-Brown-1493151865-1024x680.jpg"/>
 
<link rel='dns-prefetch' href='//assets.spin.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="SPIN &raquo; Remembering So Much for the Afterglow with Everclear&#8217;s Art Alexakis Comments Feed" href="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/feed/"/>
<link rel='stylesheet' id='mobile-zoom-css' href='http://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/css/vendor/mobile-zoom.css?ver=aabdc66e75a2a9bfbb17974175348d869ff55161' type='text/css' media='all'/>
<link rel='stylesheet' id='pi-gallery-css-css' href='http://assets.spin.com/wp-content/plugins/wp-pi-gallery/css/style.css?ver=aabdc66e75a2a9bfbb17974175348d869ff55161' type='text/css' media='all'/>
<link rel='stylesheet' id='icon-styles-css' href='http://www.spin.com/wp-content/themes/wp-theme-base/assets/css/icons.css?ver=aabdc66e75a2a9bfbb17974175348d869ff55161' type='text/css' media='all'/>
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://www.spin.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://www.spin.com/wp/wp-includes/js/underscore.min.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-widgets/js/ajax-widgets.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/jquery.lazyloadxt.extra.min.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyloadxt.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyoEmbeds.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<link rel='https://api.w.org/' href='http://www.spin.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.spin.com/wp/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.spin.com/wp/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Mac DeMarco&#8217;s &#8220;One More Love Song&#8221; May Be His Prettiest Yet' href='http://www.spin.com/2017/04/mac-demarco-one-more-love-song-stream/'/>
<link rel='next' title='Donald Trump Is So Toxic That the Restaurant in His SoHo Hotel Is Being Forced to Close' href='http://www.spin.com/2017/04/donald-trump-koi-soho-closing/'/>
<meta name="generator" content="WordPress 4.7.3"/>
<link rel='shortlink' href='http://www.spin.com/?p=237057'/>
<link rel="alternate" type="application/json+oembed" href="http://www.spin.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.spin.com%2F2017%2F04%2Feverclear-so-much-for-the-afterglow-anniversary-interview%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.spin.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.spin.com%2F2017%2F04%2Feverclear-so-much-for-the-afterglow-anniversary-interview%2F&#038;format=xml"/>
<meta property="fb:pages" content="14106370407"/><script>
    var ajax_url = 'http\x3A\x2F\x2Fwww.spin.com\x2Fajax';
</script><link rel="amphtml" href="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview?amp=1"/>
<link href='http://fonts.googleapis.com/css?family=Vollkorn:400italic,700italic,400,700' rel='stylesheet' type='text/css'>
</head>
<body itemscope itemtype="http://schema.org/Article" class="post-template-default single single-post postid-237057 single-format-image">
 
<noscript>
<iframe src="//www.googletagmanager.com/ns.html?id=GTM-N8C7Q9" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<script>
                dataLayer = [{"post id":237057,"pagetype":"article-page","author":"Winston Cook-Wilson","category":"features","published date":"2017042713","parent tag":"none","tags":"Art Alexakis, Everclear"}];
                                (function (w, d, s, l, i) {
                    w[l] = w[l] || [];
                    w[l].push({
                        'gtm.start': new Date().getTime(), event: 'gtm.js'
                    });
                    var f = d.getElementsByTagName(s)[0],
                        j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
                    j.async = true;
                    j.src =
                        '//www.googletagmanager.com/gtm.js?id=' + i + dl + '';
                    f.parentNode.insertBefore(j, f);
                })(window, document, 'script', 'dataLayer', 'GTM-N8C7Q9');</script>
 
<div id="menu" class="navbar navbar-default navbar-fixed-top " role="navigation">
<div class="container">
<div class="inner-nav-holder">
<div class="collapse navbar-collapse">
<ul class="main-nav nav navbar-nav">
<li class="  ">
<a href="http://www.spin.com/news/">
News
</a>
</li>
<li class="  ">
<a href="http://www.spin.com/new-music/">
New Music
</a>
</li>
<li class="  ">
<a href="http://www.spin.com/culture/">
Culture
</a>
</li>
<li class="logo">
<div class="navbar-header">
<a href="/" class="navbar-brand" id="logo">
<img src="http://assets.spin.com/wp-content/themes/spin/assets/images/spin-logo.svg" alt="" width="140" height="66">
</a>
</div>
</li>
<li class="  ">
<a href="http://www.spin.com/features/">
Features
</a>
</li>
<li class="  ">
<a href="http://www.spin.com/lists/">
Lists
</a>
</li>
<li class="  ">
<a href="http://www.spin.com/archives/">
The Archives
</a>
</li>
</ul>
<div class="social-and-search">
<div class="search">
<form role="search" action="/" method="GET" id="header-search">
<div class="query-holder">
<input type="text" name="s" placeholder="SEARCH" autocomplete="off">
</div>
<span class="search-submit"></span>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="social-block">
<ul class="social-links">
<li>
<a class="icon-facebook" href="http://www.facebook.com/SPIN" target="_blank"></a>
</li>
<li>
<a class="icon-twitter" href="http://www.twitter.com/spin" target="_blank"></a>
</li>
<li>
<a class="icon-instagram" href="http://www.instagram.com/SpinMagazine" target="_blank"></a>
</li>
<li class="more-social-icons">
<span class="icon-plus"></span>
<ul class="extra-1">
<li>
<a class="icon-google_plus" href="http://plus.google.com/+spinmagazine/posts" target="_blank"></a>
</li>
</ul>
</li>
</ul>
</div>
</div>
<div class="social-holder sticky-header">
<div class="social-icons">
<div class="social-container">
<div class="logo"><a href="/"></a></div>
<div class="title">Share < br />this article:</div>
<div class="email sharrre" data-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-short-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-utm-source="share-email" data-text="Remembering &lt;i&gt;So Much for the Afterglow&lt;/i&gt; with Everclear&#039;s Art Alexakis" data-title="Email"></div>
<div class="facebook sharrre" data-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-short-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-utm-source="share-fb" data-text="Remembering &lt;i&gt;So Much for the Afterglow&lt;/i&gt; with Everclear&#039;s Art Alexakis" data-title="Share"></div>
<div class="twitter sharrre" data-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-short-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-utm-source="share-tw" data-text="Remembering &lt;i&gt;So Much for the Afterglow&lt;/i&gt; with Everclear&#039;s Art Alexakis" data-title="Tweet"></div>
<div class="reddit sharrre" data-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-short-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-utm-source="share-red" data-text="Remembering &lt;i&gt;So Much for the Afterglow&lt;/i&gt; with Everclear&#039;s Art Alexakis" data-title="Reddit"></div>
</div>
</div> </div>
<div class="container ad-container">
<div class="leaderboard_top-placeholder">
<div class="leaderboard_top-holder">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class="ad_desktop leaderboard" data-position='leaderboard_top' data-sizes='[[728,91],[970,251],[970,91],[728,90],[970,250],[970,90]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='1' style="min-width: 728px; min-height: 90px; box-sizing: content-box;">
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="container main-container">
<div class="row">
<div class="sidebar-bg"></div>
<div class="col-sm-8 left-col">
<div class="article-body" itemscope itemtype="https://schema.org/Review">
<div class="article-title">
<h2 class="category">
<a href="http://www.spin.com/features/">
Features <span>\</span>
</a>
</h2>
<h1 itemprop="name" class="title">
Remembering <i>So Much for the Afterglow</i> with Everclear&#8217;s Art Alexakis
</h1>
<h2 class="subtitle"> </h2>
</div>
<div itemprop="author" itemscope itemtype="http://schema.org/Person" class="author">
<a href="http://www.spin.com/author/winston-cook-wilson/" itemprop="author">Winston Cook-Wilson</a>
<span class="date" itemprop="datePublished" content="2017-04-27T13:29:53+00:00">// April 27, 2017</span>
</div>
<div class="social-holder">
<div class="social-icons post-header">
<div class="social-container">
<div class="logo"><a href="/"></a></div>
<div class="title">Share < br />this article:</div>
<div class="email sharrre" data-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-short-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-utm-source="share-email" data-text="Remembering &lt;i&gt;So Much for the Afterglow&lt;/i&gt; with Everclear&#039;s Art Alexakis" data-title="Email"></div>
<div class="facebook sharrre" data-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-short-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-utm-source="share-fb" data-text="Remembering &lt;i&gt;So Much for the Afterglow&lt;/i&gt; with Everclear&#039;s Art Alexakis" data-title="Share"></div>
<div class="twitter sharrre" data-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-short-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-utm-source="share-tw" data-text="Remembering &lt;i&gt;So Much for the Afterglow&lt;/i&gt; with Everclear&#039;s Art Alexakis" data-title="Tweet"></div>
<div class="reddit sharrre" data-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-short-url="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/" data-utm-source="share-red" data-text="Remembering &lt;i&gt;So Much for the Afterglow&lt;/i&gt; with Everclear&#039;s Art Alexakis" data-title="Reddit"></div>
</div>
</div> </div>
<div class="featured-embed-holder format-image">
<div class="article-image-holder">
<div class="mainembed photoembed mainembed-article-embed/large align-center">
<div class="img-wrap">
<img itemprop="image" src="http://static.spin.com/files/2017/04/Everclear_Trio_Paul-Brown-1493151865-640x425.jpg" alt="Everclear_Trio_Paul-Brown-1493151865" width="640" height="425">
</div>
<div class="credit-wrapper">
<div class="credit"><small>CREDIT:</small> Paul Brown</div>
</div>
</div>
</div>
</div>
<div class="article-content-holder">
<div itemprop="articleBody" class="single-content-holder">
<div class="article-content clearfix" itemprop="reviewBody">
<p><strong><span style="font-weight: 400;"><a href="http://www.spin.com/tag/everclear/">Everclear</a>’s </span><i><span style="font-weight: 400;">So Much for the Afterglow</span></i><span style="font-weight: 400;">, which turns 20 this year, was one of the first CDs&#8211;and rock albums in any format&#8211;I ever bought. When I recently got on the phone with Art Alexakis, head singer-songwriter and the only consistent member of Everclear over their 26-year-and-counting run, I couldn&#8217;t resist telling him as much, appreciatively. </span></strong></p>
<p><strong><span style="font-weight: 400;">He chuckled. “Ah, you’re right in that demographic, eh?” </span></strong></p>
<p>I am definitely in <em>that</em> demographic. A few degrees more seamy in its subject matter than Smash Mouth&#8217;s <em>Fush Yu Mang</em> or Third Eye Blind’s debut&#8211;which I owned on cassettes which my aunt had primitively dubbed the swears out of&#8211;<i>So Much for the Afterglow</i> was one of the most alluring records I heard on rotation on cool older kids’ Discmans in 1998. The Smashing Pumpkins’ <i>Adore</i> seemed similarly dangerous, but <i>Afterglow</i> was certainly the more immediately palpable work. Even now it stands as superior: as an undeniably consistent, well-honed pop-rock compendium which saved Everclear from potential one-hit wonder status, following the success of their breakthrough hit &#8220;<a href="https://www.youtube.com/watch?v=MW6E_TNgCsY" target="_blank">Santa Monica (Watch the World Die)</a>.&#8221;</p>
<p><strong><span style="font-weight: 400;">Alexakis’ damaged power-pop anthems, which usually stuck to clear and distinctive songwriting formulas, told stories of troubled young people (&#8220;<a href="https://www.youtube.com/watch?v=UOl7lc7mc0M" target="_blank">loser geek[s] / crazy with an extra streak,</a>&#8220;) and couples addicted to each other or their controlled substances of choice. (It was the first place I remember seeing the word <a href="https://www.youtube.com/watch?v=EI1IC19rWj0" target="_blank">“Amphetamine.”</a>) There were stories of broken families, peppered with references to vague trauma and untimely deaths. The subject matter might not have been relatable to many of the kids who were naturally attracted to the music on </span><i><span style="font-weight: 400;">So Much for the Afterglow.</span></i><span style="font-weight: 400;"> But the then-35-year-old Alexakis, drawing from personal trauma as he did on their 1995 debut <a href="http://www.spin.com/2015/06/everclear-art-alexakis-sparkle-and-fade-interview-summerland/"><em>Sparkle and</em> </a></span><i><span style="font-weight: 400;">Fade, </span></i><span style="font-weight: 400;">spelled the scenarios out concisely, in terms anyone could understand&#8211;at least, they came across on a visceral level. </span><br/>
</strong></p>
<div class="mainembed videoembed mainembed-full_width align-center no-image">
<div class="video-embed-code horizontal">
<iframe width="" height="" src="https://www.youtube.com/embed/UN371tq2F0M" frameborder="0" allowfullscreen></iframe>
</div>
</div>
<p><strong><span style="font-weight: 400;">The crystalline pop-rock production&#8211;cleaner and more baroque than the band’s debut, featuring a lush overture that sounds like an </span><i><span style="font-weight: 400;">a capella</span></i><span style="font-weight: 400;"> Beach Boys warmup&#8211;made Alexakis&#8217; talking points an easier sell. The three-and-a-half-minute songs were full of carefully-applied sonic details (a banjo here, seasick string flourishes there) that betrayed the lengthy, obsessive process which brought the album to fruition. </span><br/>
</strong></p>
<p><strong><span style="font-weight: 400;">Initially, a longer, more unwieldy draft of the album called </span><i><span style="font-weight: 400;">Pure White Evil</span></i><span style="font-weight: 400;"> was rejected by the band&#8217;s label, Capitol, as not being sufficient to overcome the threat of one-hit-wonder ghettoization. The edits Alexakis made following that discouraging meeting (in a few hard months in New York, during which he claimed to have sat in diners plotting new arrangements and turns of phrase, and also </span><a href="http://www.irishtimes.com/news/ever-clearer-1.308823" target="_blank"><span style="font-weight: 400;">watching and re-watching </span><i><span style="font-weight: 400;">Jerry Macguire</span></i></a><span style="font-weight: 400;">) helped make the double-platinum </span><i><span style="font-weight: 400;">Afterglow</span></i><span style="font-weight: 400;"> a snowballing hit album hat year. It undersold under the more formidable competitors in its stylistic arena that year&#8211;Third Eye Blind’s self-titled and Matchbox 20’s </span><i><span style="font-weight: 400;">Yourself or Someone Like You</span></i><span style="font-weight: 400;">&#8211;but it holds up either as well as <a href="https://www.youtube.com/watch?v=HAkHqYlqops" target="_blank">or better than</a> those albums many years on. It boasted three major alternative rock singles “Father of Mine,” “I Will Buy You a New Life,” and the underrated lead single “Everything to Everyone,” which made SPIN&#8217;s </span><a href="http://www.spin.com/featured/best-alternative-rock-songs-1997/"><span style="font-weight: 400;">Best Alternative Rock Songs of 1997</span></a><span style="font-weight: 400;"> list.</span><br/>
</strong></p>
<p><strong><span style="font-weight: 400;">I spoke to Alexakis from his home in Los Angeles about how he remembers <em>Afterglow</em>, just before Everclear sets out on </span><a href="http://www.livenation.com/artists/167740/everclear-so-much-for-the-afterglow-20th-anniversary-tour" target="_blank"><span style="font-weight: 400;">a 20th anniversary tour to celebrate the album&#8217;s legacy</span></a><span style="font-weight: 400;"> with support from contemporaries Fastball and Vertical Horizon.</span></strong></p>
<div class="mainembed videoembed mainembed-full_width align-center no-image">
<div class="video-embed-code horizontal">
<iframe width="" height="" src="https://www.youtube.com/embed/W05cPXpUHGI" frameborder="0" allowfullscreen></iframe>
</div>
</div>
<p><strong>Did you have an idea of how the album was going to sound right from the beginning? Did you go in aiming to go in a more polished, power-poppy direction than you did on the first record?</strong></p>
<p>I’ve always loved having grinding music like that, you know, going back to like Sabbath and stuff like that, that I grew up with. Their album cover would scare me, but I listened to the record when I was like 10, 12 years old. But I’ve always loved power-pop, ever since I heard The Ramones when I was like 15. It’s not like it was a conscious thing to move in a different direction with&#8230;the melodies I was writing, but there was kind of a [different] mindset.</p>
<p>The working title for the album originally was <em>Pure White Evil.</em> I wanted it to be a combination of even heavier songs [than <em>Sparkle and Fade</em>], more punk songs, and then kind of more melodic stuff. One of my favorite bands in the world is The Band. Their first two records are just so greasy and just sloppy and fucking awesome, right?</p>
<p><strong>Yes.</strong></p>
<p>And that’s kinda what I was going for, I wasn’t going for polished.</p>
<p>We went in and recorded it in the fall at a really big studio, which was the A&amp;M Studios at the time, which is now Studio A. Before, I could barely afford to stand in the door and look inside. When I was in my twenties, I was a car messenger and I would deliver stuff there and when the girl at the front desk wasn’t looking, I’d run down the hall and look in Studio A and just fantasize until someone like kicked me out of there or some producer shut the door in my face. This was back in the ‘80s, so recording there was like a dream come true.</p>
<p>But when I got in there, that room is so fucking big that I couldn’t get a decent drum sound to save my life. We had to build like a cage around the drums just to get rid of all the ‘verb in the room, it was just so big. And I’m like, “This is what I’m paying for? I could go to a smaller room and save money and have a better drum sound.”&#8230; And every time you turned around, there was somebody asking if you wanted to like a latte or something, you know? I was coming from a place where like I had been on welfare a year-and-a-half earlier. I was just like, “Get the fuck outta here, man, I want to make a rock record!”</p>
<p>When we finally went to New York to mix [the album] at Electric Lady Studios and it was okay. It wasn’t great, but it was okay. And my A&amp;R guy told me that, he goes, “Good record, but it’s not going to do what you want it to do. It’s not going to push your career. You’re gonna hear ‘sophomore slump.’” I was just heartbroken because I hadn’t failed in a long time, I just took a couple weeks off, stayed in New York, just walked around, wrote songs in my room, saw movies and just wrote notes down, went through every song and thought about how I could make that song better. I literally had two-notebooks full of notes for ten or twelve songs.</p>
<p>I [would] go maybe walk down the street to a diner and take my notebook with me and sit at the counter and just write down notes and think of a song, just like, “What about bells on the intro to “New Life”? Like a kids piano or something,” and “I need an iconic intro to “Everything to Everyone.” A friend of mine had a Wurlitzer and so I started playing it [on “Everything to Everyone”] and I’m like, “If I put this through a bunch of effects and do like triple octaves and fifths and stuff, that’ll be the sound.”</p>
<div class="mainembed videoembed mainembed-full_width align-center no-image">
<div class="video-embed-code horizontal">
<iframe width="" height="" src="https://www.youtube.com/embed/D1vQJFF2TKQ" frameborder="0" allowfullscreen></iframe>
</div>
</div>
<p><strong>I’ve always wondered what that instrument was.</strong></p>
<p>It’s a Wurlitzer. It sounds like a synthesizer, right? It’s old, kind of off-tuned, needs to be tuned up and like the strings need to be tightened on it.</p>
<p>I wrote a song called “One Hit Wonder,” they said, “Don’t do that, that’s bad luck.” This song is kind of a “fuck you,” so a “fuck you” is always kind of bad luck. But sometimes you’ve just gotta live with it and go with it. A lot of bands at the time were signed for their one big hit. But I hadn’t even written “Santa Monica” when we were signed.</p>
<p>And so I wrote these songs and I redid them, and then my A&amp;R guy came back in. I’d never seen this motherfucker smile in his life&#8211;didn’t even know he had teeth. He’s a Brit, so I kinda suspected he <em>didn’t</em> have teeth. He turned around, smiled this huge smile, and goes, “Okay, you did it. This is the record you need.” I’m like, “Okay. Now get the fuck out of my studio, go away.” That’s exactly what I said to him.</p>
<p><strong>Was your approach to writing lyrics different for <em>Afterglow</em> than on<em> Sparkle and Fade</em> and other things you’ve done since? I feel like the narratives are very clear and direct.</strong></p>
<p>I wanted to be more of a storyteller. There was a lot of first-person songs, and there are a couple of really personal songs on there&#8211;“Father of Mine,” “New Life,” and “Why I Don’t Believe in God”&#8211;that’s a story about my mom. “Sunflowers” is such a personal song, but it’s not autobiographical. I just imagined what my mom was going through when her son died of an overdose and was in jail and prison&#8211;my older brother&#8211;and when I started going down that road of overdosing and rehab and jail and shit like that in my teens and twenties. It&#8217;s about what it’s like to watch that, because I had a child now, so I was imagining my child following in my footsteps and what that would be like.</p>
<p><strong>What was your reaction when the singles started to explode? Were you surprised at all that those songs took off to the extent that they did?</strong></p>
<p>Well, we had three songs that I thought would do well, and they did. “Father of Mine” did really well with alternative [radio]. But I had my radio people go in and they were like, “If I had a mellower version of this song, like a more acoustic-type version of this song, I could put it on these stations and these stations” and I’m like, “Okay.” I went in and put strings on it and I made it funkier and they’re like, “Well this is more R&amp;B.” And I was like, “It’s not R&amp;B. If it was R&amp;B I’d have a horns section on it.” And I’m like, “Well this is what I’m givin’ ya.” And it worked. It got played on pop [radio], which opened a whole different door as far as sales go.</p>
<div class="mainembed videoembed mainembed-full_width align-center no-image">
<div class="video-embed-code horizontal">
<iframe width="" height="" src="https://www.youtube.com/embed/kkcbxjWG9Mc" frameborder="0" allowfullscreen></iframe>
</div>
</div>
<p><strong>Are people you got to meet, or experiences that you had during that time, that were particularly important for you, or felt like, &#8220;Wow, this is unbelievable&#8221;?</strong></p>
<p>When we put out <em>Afterglow</em> and we did the press junk for it in New York, Janeane Garofalo, who was a huge fan of <em>Sparkle and Fade</em>, was there with someone from Rolling Stone that had panned the first record. Janeane would not leave this guy alone&#8211;she was like an attack dog on him about what he’d written about <em>Sparkle and Fade</em>. I feel sorry for the dude, man; she was just vicious. That was a trip.</p>
<p>I met all sorts of people&#8211;movie stars and people who like were huge fans of those two records and would come to shows and stuff. I had like famous starlets and models and stuff, and was like “Oh, this is what that feels like.” It seemed fake and very, like, fleeting. Like these people are going, “Oh, I’m your biggest fan.” Yeah, sure you are. I didn’t buy into any of it, but I tried to enjoy it.</p>
<p>I wish I had enjoyed that stuff more, I guess, and gone to the big parties that I didn’t go to. I probably would’ve helped my career a lot if I had went to those instead of marrying poor waitresses. I got married four times&#8211;I might as well have married a movie star somewhere in there. But, nope, didn’t do it. <em>[awkward pause]</em> That’s sarcasm. I have to say that because sometimes people like quote me exactly, and I’m like, “Dude! I was joking! It was a joke.”</p>
<p><strong>After <em>Afterglow</em>, when you were doing your next record [<em>Songs from an American Movie Vol. 1</em>], <em>TRL</em> was coming to prominence. Rap-rock and boy bands started to dominate the charts. Did you feel like Everclear was out of place in that landscape? Did you like the new musical styles that were developing during that time?</strong></p>
<p>I really liked alternative radio at the time [of <em>Afterglow</em>] because, frankly, there was big guitars on the radio. I just enjoyed that. I don’t know if you know it, but I have <a href="http://blog.siriusxm.com/2017/03/03/the-art-alexakis-show-comes-to-lithium-hosted-by-the-everclear-frontman/" target="_blank">a show</a> on SiriusXM, on the ‘90s station Lithium, on Sunday nights. And I get to play, not just the hits, but Failure, Sonic Youth, and just, like, Liz Phair’s <em>Exile in Guyville</em>. I get to delve into the songs that help me remember what the ‘90s really were&#8211;particularly the late ‘80s and in the early ‘90s. There’s a level of nostalgia there, but also just lots of great songs that people don’t know about.</p>
<p>I feel like in the transitional stage&#8211;‘98, ‘99, right before all that nu-metal shit came out, right?&#8211;[things] got so poppy that it opened up the door for this kind of reaction from kids where they wanted something of their own, and that’s where the whole big metal rebirth came in. That’s kind of my memory of it. But you know, I liked it all. I liked the heavy stuff.</p>
<p>In 2000, we put out <em>Vol. 1</em> of <em>Songs From an American Movie</em>, which was more poppy and then <em>Vol. 2</em>, which was more rock. But I wish I had just made one record. I think some of that second record is starting to sound tired, because I was tired, you know? I just sound tired.</p>
<div class="mainembed videoembed mainembed-full_width align-center no-image">
<div class="video-embed-code horizontal">
<iframe width="" height="" src="https://www.youtube.com/embed/qZEnI9PTPTs" frameborder="0" allowfullscreen></iframe>
</div>
</div>
<p><b>Do you have any regrets about that time period, or about the album itself? Anything you wish you’d done differently?</b></p>
<p><span style="font-weight: 400;">To be honest with you, man, I don’t think I’d change that record one bit. I hear some off-tune stuff here and there&#8211;ehh. It’s like fine leather: There’s gonna be scars on it. I don’t have a problem with that. </span></p>
<p><span style="font-weight: 400;">Things I regret? Yeah, I wish I had tried harder in my marriage and not done a lot of the things I’d done, y’know? I regret that. I wish I had spent less time working on the record, and more time at home, but I think that that was going to go the way it was going to go anyways. If it hadn’t gone that way, I wouldn’t be where I’m at now. And I love my life now, I love my family&#8211;everything’s great. With those kind of regrets, it’s kinda like that movie </span><i><span style="font-weight: 400;">Sliding Doors</span></i><span style="font-weight: 400;">, you know. Where would I be then? Would I be better? I don’t know. </span></p>
<div class="author-footer">
<div class="inner">
<div class="avatar">
<a href="http://www.spin.com/author/winston-cook-wilson/"><img alt='' src='http://2.gravatar.com/avatar/e7080d7334f409fe30104b1012f2958a?s=60&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/e7080d7334f409fe30104b1012f2958a?s=120&amp;d=mm&amp;r=g 2x' class='avatar avatar-60 photo'/></a>
</div>
<div class="text">
<div class="name">
<a href="http://www.spin.com/author/winston-cook-wilson/">Winston Cook-Wilson</a>
</div>
<div class="list">
<ul>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="row tags-and-comments">
<div class="col-sm-9">
<div itemprop="keywords" class="tags">
<strong>Tags:</strong>
<a href="http://www.spin.com/tag/art-alexakis/">Art Alexakis</a>, <a href="http://www.spin.com/tag/everclear/">everclear</a> </div>
</div>
<div class="col-sm-3">
<div itemprop="comment" class="comments right">
<a href="#disqus_thread"><span class="count disqus-comment-count" data-disqus-identifier="237057 http://www.spin.com/?p=237057"></span><span class="article-comment-bubble"></span></a>
</div>
</div>
</div>
</div>
</div>
<hr>
<div class="zergnet-holder">
<div class="zergnet-widget" id="zergnet-widget-33039"></div>
<script language="javascript" type="text/javascript">
        (function () {
            var zergnet = document.createElement('script');
            zergnet.type = 'text/javascript';
            zergnet.async = true;
            zergnet.src = 'http://www.zergnet.com/zerg.js?id=33039';
            var znscr = document.getElementsByTagName('script')[0];
            znscr.parentNode.insertBefore(zergnet, znscr);

            zergnet.onload = function(){ 
                window.dataLayer = window.dataLayer || [];
                var zergnetId = '33039';

                if(zergnetId) {
                    window.dataLayer.push({
                        'event': 'zergnet',
                        'action': 'loaded',
                        'label': zergnetId
                    }); 
                }
            };
        })();
    </script>
</div>
<div class="link-exchanges">
<div class="recommended-module ">
<div class="title-holder">
<h2>Recommended for you <span class="red">\</span></h2>
</div>
<div class="row">
</div>
<div class="row">
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-review/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
<img src="http://static.spin.com/files/2017/04/so-much-for-the-afterglow-1493063636-191x127.jpg" width="191" height="127" alt="Review: Everclear &#8211; <i>So Much for the Afterglow</i>">
</a>
</div>
<div class="preview-holder">
<a href="http://www.spin.com/2017/04/everclear-so-much-for-the-afterglow-review/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
<h3>
Review: Everclear &#8211; <i>So Much for the Afterglow</i>
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.spin.com/2015/06/everclear-art-alexakis-sparkle-and-fade-interview-summerland/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
<img src="http://static.spin.com/files/2015/06/ART-Paul-Brown-191x127.jpg" width="191" height="127" alt="Everclear&#8217;s Art Alexakis: &#8221;Sparkle and Fade&#8217; Was My Escape Route&#8217;">
</a>
</div>
<div class="preview-holder">
<a href="http://www.spin.com/2015/06/everclear-art-alexakis-sparkle-and-fade-interview-summerland/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
<h3>
Everclear&#8217;s Art Alexakis: &#8221;Sparkle and Fade&#8217; Was My Escape Route&#8217;
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.spin.com/2014/10/everclear-u2-windows-10-commercial-funny-or-die/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
<img src="http://static.spin.com/files/./141003-everclear-windows_1-191x127.jpg" width="191" height="127" alt="Everclear Pull a U2, Partner With Windows 10 for Intrusive Album Release">
</a>
</div>
<div class="preview-holder">
<a href="http://www.spin.com/2014/10/everclear-u2-windows-10-commercial-funny-or-die/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
<h3>
Everclear Pull a U2, Partner With Windows 10 for Intrusive Album Release
</h3>
</a>
</div>
</div>
</div>
<div class="row">
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.spin.com/2013/03/everclear-summerland-2013-alternative-guitars-tour/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
<img src="http://static.spin.com/files/130325-everclear-191x127.jpg" width="191" height="127" alt="Everclear Continue to Bleed &#8217;90s Nostalgia With Summerland 2013 Tour">
</a>
</div>
<div class="preview-holder">
<a href="http://www.spin.com/2013/03/everclear-summerland-2013-alternative-guitars-tour/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
<h3>
Everclear Continue to Bleed &#8217;90s Nostalgia With Summerland 2013 Tour
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.spin.com/2017/04/haim-right-now-review/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
<img src="http://static.spin.com/files/2017/04/Screen-Shot-2017-04-27-at-4.15.03-PM-1493324131-191x127.png" width="191" height="127" alt="Haim&#8217;s &#8220;Right Now&#8221; Is an Understated but Welcome Return">
</a>
</div>
<div class="preview-holder">
<a href="http://www.spin.com/2017/04/haim-right-now-review/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
<h3>
Haim&#8217;s &#8220;Right Now&#8221; Is an Understated but Welcome Return
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.spin.com/2017/04/damien-chazelle-tv-show-paris/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
<img src="http://static.spin.com/files/2017/04/damien-chazelle-2016-oscars-billboard-1548-1493322186-1493323245-191x127.jpg" width="191" height="127" alt="<i>La La Land</i> Director Damien Chazelle Planning TV Drama About Paris Music Scene">
</a>
</div>
<div class="preview-holder">
<a href="http://www.spin.com/2017/04/damien-chazelle-tv-show-paris/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
<h3>
<i>La La Land</i> Director Damien Chazelle Planning TV Drama About Paris Music Scene
</h3>
</a>
</div>
</div>
</div>
</div>
</div>
<div id="amazon-widget"></div>
<script type="text/javascript">
                        additional_search = "above $20";
                        amzn_assoc_ad_mode = "search";
                        amzn_assoc_ad_type = "smart";
                        amzn_assoc_div_name = "amazon-widget";
                        amzn_assoc_marketplace = "amazon";
                        amzn_assoc_placement = "smart1";
                        amzn_assoc_region = "US";
                        amzn_assoc_rows = "1";
                        amzn_assoc_search_bar = "false";
                        amzn_assoc_title = "Available at Amazon";
                        amzn_assoc_tracking_id = "spin049-20";
                        categories = "Array";
                    </script>
<script type="text/javascript" src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&source=ac"></script>
<div id="disqus_thread">
</div>
</div>
<div class="col-sm-4 sidebar">
<div class="sm-widget sm-widget-ad-holder"><div class="sm-widget-ad"> <div class="ad_desktop" data-position='medrec_top' data-sizes='[[300,251],[300,601],[300,250],[300,600]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='2' style="min-width: 300px; min-height: 250px; box-sizing: content-box;">
</div>
</div></div><div class="sidebar-module ">
<div class="feed feed-tile"><div class="title-holder clearfix"><div class="title left"><a href="http://www.spin.com/reviews/"><h2>
Reviews
<span class="red">\</span></h2></a></div><div class="see-all right"><a href="http://www.spin.com/reviews/">Read More &raquo;</a></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="http://www.spin.com/2017/04/thurston-moore-rock-n-roll-consciousness-review/" class=" ga-product-impression" data-list-name="Reviews - article-page" data-list-position="1"><img src="http://static.spin.com/files/2017/04/thurston-moore-rock-roll-consciousness-album-1493307942-145x145.png" alt="Review: Thurston Moore&#8217;s <i>Rock n Roll Consciousness</i> Is His Most Transportive Solo Record Yet"></a></div><div class="preview-holder"><a href="http://www.spin.com/2017/04/thurston-moore-rock-n-roll-consciousness-review/" class="title-link  ga-product-impression" data-list-name="Reviews - article-page" data-list-position="1">Review: Thurston Moore&#8217;s <i>Rock n Roll Consciousness</i> Is His Most Transportive Solo Record Yet</a></div><div class="overlay"></div></div><div class="post"><div class="image-holder"><a href="http://www.spin.com/2017/04/gorillaz-humanz-review/" class=" ga-product-impression" data-list-name="Reviews - article-page" data-list-position="2"><img src="http://static.spin.com/files/2017/04/humanz_1200x-1493309049-145x145.jpg" alt="Review: <i>Humanz</i> Proves Gorillaz Are Better With Damon Albarn Out of the Spotlight"></a></div><div class="preview-holder"><a href="http://www.spin.com/2017/04/gorillaz-humanz-review/" class="title-link  ga-product-impression" data-list-name="Reviews - article-page" data-list-position="2">Review: <i>Humanz</i> Proves Gorillaz Are Better With Damon Albarn Out of the Spotlight</a></div><div class="overlay"></div></div></div><div class="posts clearfix"><div class="post"><div class="image-holder"><a href="http://www.spin.com/2017/04/colin-stetson-all-this-i-do-for-glory-review/" class=" ga-product-impression" data-list-name="Reviews - article-page" data-list-position="3"><img src="http://static.spin.com/files/2017/04/ColinStetson-1493215439-145x145.jpg" alt="Review: Colin Stetson Is a Thrilling One-Man Band on <i>All This I Do For Glory</i>"></a></div><div class="preview-holder"><a href="http://www.spin.com/2017/04/colin-stetson-all-this-i-do-for-glory-review/" class="title-link  ga-product-impression" data-list-name="Reviews - article-page" data-list-position="3">Review: Colin Stetson Is a Thrilling One-Man Band on <i>All This I Do For Glory</i></a></div><div class="overlay"></div></div><div class="post"><div class="image-holder"><a href="http://www.spin.com/2017/04/review-depeche-mode-ultra/" class=" ga-product-impression" data-list-name="Reviews - article-page" data-list-position="4"><img src="http://static.spin.com/files/2017/04/depeche-ultra-f1-1493222143-145x145.jpg" alt="Review: Depeche Mode &#8211; <i>Ultra</i>"></a></div><div class="preview-holder"><a href="http://www.spin.com/2017/04/review-depeche-mode-ultra/" class="title-link  ga-product-impression" data-list-name="Reviews - article-page" data-list-position="4">Review: Depeche Mode &#8211; <i>Ultra</i></a></div><div class="overlay"></div></div></div></div></div><div class="sidebar-module sm-widget sm-widget-campaign-monitor text-center">
<div class="widget-head">
<h1>Bull Sessions.</h1>
<h3>Sign up for the SPIN newsletter and stay in the know.</h3>
</div>
<div class="widget-content">
<div class="success hidden">
Thank you for signing up for our newsletter. You will receive a confirmation shortly.
</div>
<form action="http://spinmedia1.createsend.com/t/i/s/jjhujd/" method="post" class="cm-form">
<input id="fieldEmail" name="cm-jjhujd-jjhujd" type="email" required placeholder="Enter email address"/>
<button type="submit" name="cm_submit">Submit</button>
<div class="error" class="hidden">
</div>
</form>
</div>
</div><div class="sm-widget sm-widget-ad-holder"><div class="sm-widget-ad"> <div class="ad_desktop" data-position='medrec_bottom_lazy' data-sizes='[[300,250],[300,600]]' data-lazy-load='1' data-refresh='1' data-refresh-timer='15' data-swap='' data-load-order='' style="min-width: 300px; min-height: 250px; box-sizing: content-box;">
</div>
</div></div>
</div>
</div>
</div>
<div class="container footer-ad-holder">
<div class="leaderboard-wrapper">
<div class="ad_desktop leaderboard" data-position='leaderboard_bottom_lazy' data-sizes='[[728,90],[970,250],[970,90]]' data-lazy-load='1' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='' style="min-width: 728px; min-height: 90px; box-sizing: content-box;">
</div>
</div>
</div>
<div class="footer-recommended">
<div class="container">
<h3>Editor's Picks</h3>
<div class="row">
<a href="/2016/08/96-best-alternative-rock-songs-1996/">
<div class="post col-sm-4">
<div class="overlay"></div>
<div class="img-wrap">
<img src="http://static.spin.com/files/2016/08/90s-alt-wide-313x209.png" width="313" height="209" alt="The 96 Best Alternative Rock Songs of 1996">
</div>
<div class="title">
<div>The 96 Best Alternative Rock Songs of 1996</div>
</div>
</div>
</a>
<a href="/2017/03/discogs-most-expensive-record-billy-yeager/">
<div class="post col-sm-4">
<div class="overlay"></div>
<div class="img-wrap">
<img src="http://static.spin.com/files/2017/03/Screen-Shot-2017-03-23-at-9.04.22-AM-1490274298-313x209.png" width="313" height="209" alt="The Unbelievable Story of the Most Expensive Record Ever Sold on Discogs">
</div>
<div class="title">
<div>The Unbelievable Story of the Most Expensive Record Ever Sold on Discogs</div>
</div>
</div>
</a>
<a href="/2015/05/these-will-be-the-years-the-100-greatest-edm-anthems-of-the-10s/">
<div class="post col-sm-4">
<div class="overlay"></div>
<div class="img-wrap">
<img src="http://static.spin.com/files/2015/05/EDM-2-313x209.jpg" width="313" height="209" alt="These Will Be the Years: The 100 Greatest EDM Anthems of the '10s">
</div>
<div class="title">
<div>These Will Be the Years: The 100 Greatest EDM Anthems of the '10s</div>
</div>
</div>
</a>
</div>
</div>
</div>
<footer id="footer">
<div class="container">
<div class="comscore">
<div class="comscore-header clearfix">
<div class="right">
<div class="mobile-site-footer">
</div>
<div class="footer-logo">
<a href="/">
<img src="http://assets.spin.com/wp-content/themes/spin/assets/images/spin-logo.svg" alt="" width="92" height="43">
</a>
</div>
</div>
<div class="left">
<ul class="social-links">
<li>
<a href="http://www.facebook.com/SPIN" target="_blank">
<div class="social-icon square facebook">
<span class="icon-facebook"></span>
</div>
</a>
</li>
<li>
<a href="http://www.twitter.com/spin" target="_blank">
<div class="social-icon square twitter">
<span class="icon-twitter"></span>
</div>
</a>
</li>
<li>
<a href="http://www.instagram.com/SpinMagazine" target="_blank">
<div class="social-icon square instagram">
<span class="icon-instagram"></span>
</div>
</a>
</li>
</ul>
<div class="menu">
<a href="http://www.spin.com/news" alt="news">NEWS</a>
<a href="http://www.spin.com/new-music" alt="new music">NEW MUSIC</a>
<a href="http://www.spin.com/culture" alt="culture">CULTURE</a>
<a href="http://www.spin.com/features" alt="features">FEATURES</a>
<a href="http://www.spin.com/lists" alt="lists">LISTS</a>
<a href="http://www.spin.com/archives" alt="the archives">THE ARCHIVES</a>
<a href="/cdn-cgi/l/email-protection#295d40595a695a594047074a4644" alt="contact us">CONTACT US</a>
</div>
<span class="site-name">SPIN</span>.com is a member of Billboard Music, a division of Billboard-Hollywood Reporter Media Group.
<div class="comscore-header-links">
<a class="comscore--link comscore--header-link" href="/about">About <span class="comscore--bold">Spin</span></a>
<a class="comscore--link comscore--header-link" href="/privacy-policy" rel="nofollow" target="_blank">Privacy Policy</a>
<a class="comscore--link comscore--header-link" href="/about-our-ads" rel="nofollow" target="_blank" class="cs_aboutBug">
<img src="//lib.pgmcdn.com/choices/collisionadmarkerwht.png" alt="adChoices" class="comscore--img">
</a>
<a class="comscore--link" href="/copyright" rel="nofollow" target="_blank">Copyright</a>
</div>
</div>
</div>
<div class="comscore--body">
<a class="comscore--link" href="http://www.billboard.com" target="_blank">Billboard</a> |
<a class="comscore--link" href="http://www.hollywoodreporter.com/" target="_blank" rel="nofollow">The Hollywood Reporter</a> |
<a class="comscore--link" href="http://www.spin.com/" target="_blank" rel="nofollow">SPIN</a> |
<a class="comscore--link" href="http://www.vibe.com/" target="_blank" rel="nofollow">VIBE</a> |
<a class="comscore--link" href="http://www.deathandtaxesmag.com/" target="_blank" rel="nofollow">deathandtaxesmag</a> |
<a class="comscore--link" href="http://www.stereogum.com/" target="_blank" rel="nofollow">Stereogum</a>
</div>
</div>
</div>
</footer>
<script type="text/javascript">
        // Asynchronous Loading
        var script = document.createElement("script");
        script.src = script.src = document.location.protocol + '//platform.twitter.com/widgets.js';
        script.async = true;
        document.getElementsByTagName("body")[0].appendChild(script);
    </script>
<script id="ad_slot" type="text/template">
            <div class="ad_desktop" data-sizes="[[160,600],[300,250],[300,600]]" data-position="300c"></div>
        </script>
<div id="hidden_div" class="hidden"></div>
<div id="ad_native_instream" class="ad_desktop" data-sizes="[2,2]" data-position="native_instream_lazy"></div>
<div id="ad_native_rightrail" class="ad_desktop" data-sizes="[2,2]" data-position="native_detail_lazy"></div><script type="text/html" id="sc_interrupter_template">
<div class="post row wp-pi-sponsored-content-interrupter">
    <div class="posts-holder"> 
                    <div class="interrupter-post"> 
            <div class="image-holder"> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <img src="<% if(typeof post_images == "object") { print(post_images.feed.split) } %>"> 
            </a> 
            <div class="text-overlay">
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>>
                    <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                </a>
            </div> 
        </div> 
        <div class="preview-holder"> 
                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                <div class="shared-by">
                    <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                </div>
            <% } %>    
                <h2> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <% if(typeof post_title !== "undefined") { print(post_title) } %>
            </a> 
        </h2> 
        <% if(typeof sponsor_image !== "undefined") { %>
            <div class="sponsor"> 
                                <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %>

                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                    <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                </a> 
                
                                <% if((typeof show_sponsor === "undefined" || show_sponsor )
                        && typeof sponsor_name !== "undefined") { %>
                    <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %>
                    <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                        <span>
                            <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                        </span>
                    </a> 
                <% } %>
            </div> 
        <% } %>
                <div class="preview"> 
            <% if(typeof post_preview !== "undefined") { print(post_preview) } %>
        </div> 
            </div> 
</div>            </div> 
</div>
</script><script type="text/html" id="sc_interrupter_template_sidebar">
<div class="sidebar-module wp-pi-sponsored-content-interrupter"> 
    <div class="title-holder clearfix"> 
            <div class="title left"> 
        <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>">
            <h3>
                <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                <span class="red">\</span>
            </h3>
        </a>
    </div> 
    </div> 
    <div class="posts-holder"> 
        <div class="interrupter-post"> 
            <div class="image-holder"> 
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>> 
                    <img src="<% if(typeof post_images == "object") { print(post_images.sidebar) } %>">
                </a> 
            </div> 
            <div class="preview-holder"> 
                                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                        <div class="shared-by">
                            <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                        </div>
                    <% } %>    
                                <h2> 
                    <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>>
                        <% if(typeof post_title !== "undefined") { print(post_title) } %>
                    </a> 
                </h2> 
                <% if(typeof sponsor_image !== "undefined") { %>
                     
                        <div class="sponsor">
                                                        <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                            
                            <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                            </a> 
                            <% if((typeof show_sponsor === "undefined" || show_sponsor)
                                    && typeof sponsor_name !== "undefined") { %>
                                <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                    <span>
                                        <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                                    </span>
                                </a> 
                            <% } %>
                        </div> 
                     
                <% } %>
            </div> 
        </div> 
    </div> 
</div>
</script><script type="text/javascript">
    var disqus_config = function () {
        this.callbacks.onNewComment = [function () {
            dataLayer.push({
               'event': 'disqus-event',
               'category': 'Comments',
               'action': 'New Comment',
               'label': '/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/'
            });
        }];

        this.callbacks.onPaginate = [function (e) {
            dataLayer.push({
               'event': 'disqus-event',
               'category': 'Comments',
               'action': 'Pagination',
               'label': '/2017/04/everclear-so-much-for-the-afterglow-anniversary-interview/'
            });
        }];
    };
</script> <div class="ad_desktop" data-position='out_of_page' data-sizes='[[1,1]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='3' data-out-of-page='true' style="display: none;">
</div>
<script>CLARITY.push({use:['ads'],run:function(Ads){Ads.site_code="spin";if(!Ads.zone){Ads.zone="article_page";}
var keywords=[];keywords.push({keywords:"",keyvalues:"post_id=237057",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"category=features",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"category=interviews",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"category=uncategorized",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"tags=art-alexakis,everclear",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"url=3a445443",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"pagetype=article_page",paths:"",positions:"all"});Ads.keywords=keywords;Ads.optionDefaults=Ads.optionDefaults||{};Ads.autoPopulate();}});</script> <script type="text/html" id="pe_zoom_overlay">
        <div class="pe-zoom-overlay scroll-<%= scroll_dir %>">
            <div class="image-holder">
                <img itemprop="image"
                     src="<%= img_src %>">
            </div>
            <div class="pe-zoom-close-x"></div>
        </div>
    </script><link rel='stylesheet' id='ad-css-css' href='http://assets.spin.com/wp-content/plugins/wp-pi-clarity/css/clarity.css?ver=aabdc66e75a2a9bfbb17974175348d869ff55161' type='text/css' media='all'/>
<link rel='stylesheet' id='photo-zoom-css' href='http://assets.spin.com/wp-content/plugins/wp-pi-mainembed/css/photo-zoom.css?ver=aabdc66e75a2a9bfbb17974175348d869ff55161' type='text/css' media='all'/>
<link rel='stylesheet' id='zergnet-article-css-css' href='http://assets.spin.com/wp-content/plugins/wp-pi-zergnet/css/article.css?ver=aabdc66e75a2a9bfbb17974175348d869ff55161' type='text/css' media='all'/>
<script type='text/javascript'>
/* <![CDATA[ */
var mobileDetect = {"isMobile":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.spin.com/wp-content/plugins/wp-pi-mobile-theme/js/mobile_detect.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/img-touch-canvas.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.spin.com/wp/wp-includes/js/wp-util.min.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/mobile-zoom.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-sponsored-content/js/interrupter/interrupter.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/js/bootstrap.min.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/lodash.2.4.1.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://www.spin.com/wp-content/themes/wp-theme-base/assets/js/all.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://www.spin.com/wp-content/themes/spin/assets/js/all.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://www.spin.com/wp/wp-includes/js/wp-embed.min.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://www.spin.com/wp-content/plugins/wp-pi-sharrre/js/jquery.sharrre.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://www.spin.com/wp-content/plugins/wp-pi-sharrre/js/sharrre-init.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-clarity/js/sticky.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.3","language":""},"disqusIdentifier":"237057 http:\/\/www.spin.com\/?p=237057","disqusShortname":"spinmedia","disqusTitle":"Remembering <i>So Much for the Afterglow<\/i> with Everclear\u2019s Art Alexakis","disqusUrl":"http:\/\/www.spin.com\/2017\/04\/everclear-so-much-for-the-afterglow-anniversary-interview\/","options":{"manualSync":"1"},"postId":"237057"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.spin.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript' src='http://assets.spin.com/wp-content/plugins/wp-pi-campaign-monitor/js/campaign_monitor.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"spinmedia"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.spin.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=aabdc66e75a2a9bfbb17974175348d869ff55161'></script>
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>